Smartthings Not Updating Zone Status (on/off)

For some reason Smartthings is not updating a zone’s status if it is toggled on or off by/from the Rachio app. The status is always off. If I start a zone from the Smartthings app, the status is correctly updated.

The reason this matters is that the Rachio Daily Flex schedule will start itself and I need to disable some other devices when it does. I don’t see how I can trigger off that with this bug (Alexa can’t trigger off the zone status) Is it a known issue? Any workarounds?