Smart hose timer hub setup fails at phone connection

I attempted to add the hub to my home again and again, but the app or device appears to be defective.

For the steps suggested, I was able to complete the first 3:

  1. Add the Hub from the app in the plus blue sign and select Smart HoseTimer.
  2. Select my home.
  3. Connect the HUB to power the adapter until the light is yellow. (This is required) Next.

Then on step 4, it fails:
4. Scan the QR code on the Rachio HUB or add it manually.

I scan the QR code and select the Rachio Hub wifi, which appears connected:

But when I return to your app, it just hangs here:

I can’t reach steps 5 or 6:
5. Chose network, next. (Please make sure to select your network instead of the hub).
6. Wifi password, Hit next and connect.

I’ve reset/connected/disconnected multiple times. I’ve created a new home and received similar failure. Any thoughts or is this a defective return item?

I had trouble connecting mine too. After many times, it connected and have been fine there. Do you have a Rachio 3 or similar controller for sprinklers connected as well? What type of phone and wireless router?


Thank you for bringing this to our attention. I know WiFi connection issues are frustrating and I’m sorry that you’ve had to go through it over and over. I’m confident that either myself or someone on our Support team can get this resolved for you.

There can be a variety of factors that prevent the hub from successfully connecting to WiFi and it can be difficult to nail it down. However, what you are experiencing might be related to a specific issue that we have recently identified and are working on a fix. To confirm if this is the case, and possibly resolve your issue could you try to connect to your WiFi access point through the manual entry option?

  • This is on the screen that reads “Select your network” at the top - right after you connect to the hub through WiFi settings and go back to the app.
  • You will see “Enter Manually” above “Learn More”.
  • Then enter your SSID (making sure that it matches your SSID exactly - it must be a 2.4 Ghz network or 2.4/5 Ghz network

If you still get an error our Support team can help you.

I look forward to hearing about your results.

I have an iPhone X and a Rachio 3 controller with a Tempest weather station already in my app. Once I get to where the iPhone wifi indicates it is connected to the Rachio hub, the Rachio app never recognizes the iPhone connection. The app just hangs there. I never get to the “Select your network” screen.

I am not able to get to the step 5. Chose network. The app just hangs in step 4.

That fact that you can’t get past step 4 doesn’t seem right. If this is a defect with the hardware, we’ll get you a new hub asap. Do you want to direct message me and we’ll get that going?

One last question: you aren’t by any chance on a mobile VPN?

@rachio_user_24 -

Try these two things:

  1. Restart your phone.

  2. If your WiFi is set to WPA3 or WPA2/3, try changing it to WPA2 - just to see if it connects.

Other questions: which WiFi channel is being used by the router? Make of the WiFi router/access point?

Restarted my iPhone and verified I’m on WPA2 with an Asus RT-AC68U. It looks like control channel 2 on the ASUS. Still hangs after phone appears connected to hub and never reaches step to select wifi network. Oddly, with another user’s account on their iPhone, the hub was able to be added while they used my Asus wifi. When I shared complete access of my account to that user, they were not able to add the hub to my home, but were able to add another home and then add the hub, get firmware updates, and operate a hose valve. When I attempted to add another home and then add the hub, it gets to where the iPhone shows it is connected to the hub, the hub light turns green, and then it still hung before reaching the select network step.

Ok, this does seem to be phone specific. A couple of options:

  1. We can setup some time to troubleshoot your phone
  2. If you have access to another phone that you can log into your account with, you can add it that way

Any preferences?

Also, did you see my note about having a VPN turned on?

On the sharing side, we have not yet released shared access for our hose end timer. We’ll be releasing that in the next few weeks, and then it will be sharable.


Chris, I have been unable to connect since I first purchased the smart hose timer/hub 2 months ago. I have spent over 3 hours on the phone with support over 2 occasions. you have sent me a replacement hub and I am still not able to connect. We did connect using my ipad and as a hub but never to the system.I have tried connecting to guest… I am using Eero mesh, iPhone 13 …I disable 5ghz …use no VPN…is there a fix for this yet? I see I am not alone in the failure to connect.

@biznews - If your Eero setup has WPA2/WPA3 set it to WPA2 only for the setup and see if that works.

Thanks @DLane for the additional troubleshooting. That’s a good point.

@biznews if that doesn’t work, DM me and we’ll figure out what we need to do to either get you up and running or make it right for you. From everything you’ve mentioned about setup, this should work. And it doesn’t seem like a hardware defect since you’ve tried it on two different hubs.

I had the same problem. First, I made sure my VPN was disconnected. Then I tried resetting everything, rebooting my phone, retrying everything multiple times. All with the same result. It was very frustrating.

I started digging through all my settings and noticed the Local Network setting in Privacy and Security (IOS). It was turned off for the Rachio app. I turned it on, went through the process again, and it finally worked.

I hope that helps someone else. Good luck!

Finally got the hub to connect and into my account via an iPhoneX. As Ersinatx noted, Settings → Privacy & Security → Local Network to allow the Rachio app to find devices on the network.

@rachio_user_24 thanks for letting us know that worked. @Ersinatx thank you for recommending the fix. We’ll take a look at this as we release a new update for iOS onboarding that will use Bluetooth.