Smart hose timer hub fails to connect

Hello, I am really hoping for some help connecting the hub to my 2.4ghz network. I spent a ton of time with rachio support today without any success using both android and apple devices. I was able to get the hub/valve to connect only when using my one phone as a hotspot and using the app on another device which allowed all updates being done on both hub and valve. When I went to then update my hub wifii back to the 2.4ghz it asks me for my password which I typed in and it fails over and over again (password is correct as I tripple checked forgetting the 2.4ghz network and reconnecting using the same password which connected right away). Router and modem have been power cycled 3 times.
Because it works with the phone as a hotspot and not the 2.4ghz it leads me to believe it is something with the settings with my router or the hub is deffective (I have 2 hubs & valves which both expierence the same issues). My rachio 3 controller is on the 2.4ghz and works perfect as I have had that for a number of years. I have also tried to do everything including trying to setup only 5ft away from the router just to make sure it wasn’t a signal issue. The router is a linksys wrt3200acm with all firmware updates done.
Security mode: WPA2 Personal, Broadcast SSID: Yes, Wi-Fi mode: Mixed, Channel: Auto, Channel width: Auto
On reddit I am seeing people with issues connecting as well.

I appreciate any help!!

@rachio_user - I had the exact same issue.

I was able to solve it by manually specifying the network name instead of picking it from the list.

I take it that there is only one access point for the SSID.

1 Like

Hi DLane, I had tried the manual method earlier today without any success while on the phone with rachio support as they had me try but thought after your reply to my post to try it again (I tried most everything again tonight without success besides that lol!). I first went to my android phone and tried but it did not allow for the network to be manually entered as the only options were to select from the available networks list but then grabbed my ipad as I knew for certain that had the option earlier. I entered everything in manually and sure enough if it connected, I was shocked it worked!!! I closed the app and everything back on my android phone and reopened it just to make sure it wasn’t just the apple app that would end up working but everything is there so it appears I am all set. Thank you kindly for your help!!!


Where are you seeing the manual entry for the network SSID? I do not see that in the app. After I scan the hub, go in and select the hub address, the app just keep spinning and doesn’t get to the next step. Have tried iPhone and iPad and have rebooted both. I never get to the step to even connect to my Wi-Fi network.

Do you have the latest version of iOS? In iOS Settings->Privacy Security->Local Network is the Rachio app toggled on (green)?

@Planowulfes - I don’t think the Android version of the app has the manual network prompt. Are you using the Android or iOS version of the Rachio app?

Check the WiFi configuration, if it is set for WPA2/WPA3 set it to WPA2 only for the setup and see if that works.

Rachio app is not even in the list under Privacy & Security. However, immediately under Settings where all apps are listed, the Rachio app is listed as well, and yes, the Local Network is on (green).