Schedules with rain skip *disabled* still get rain delay applied


#1

I have several schedules for my property covering the lawn, a veggie garden and several flower gardens covered and non-covered) all on different zones. For some of these schedules, rain skip is enabled with appropriate thresholds. For other zones, i have disabled rain skip since they may be annuals under shelter that would not actually receive rainwater if there was precipitation.

My issue is that on any day where there is enough rain forecasted to cause a rain delay for schedules that observe it, this also causes other schedules to also skip watering even if those schedules have rain skip disabled!

The bug is not so apparent in the App GUI, however, its easy to spot and easy to see when your zones are not getting water. You will typically see a message in the schedule updates indicating a rain delay for an observant schedule:

Water Lawn skipped since station KWRI observed 0.16 in and predicted 0.37 in of precipitation with a total threshold of 0.125

Then you’ll see a non-observant schedule print a msg ignoring the rain delay:

Water Front Flower Pots was not skipped since the forecast service observed 0.0 in and predicted 0.0 in of precipitation and the total threshold is 0.125 in

After that, the schedule will NOT actually trigger and there will not be any record of it in the Watering History. And its not just a phantom message either, absolutely no water will be sent to these zones and i have several that are affected by this bug. Basically i have to constantly look for missed waterings and run schedules manually thereby defeating the intelligence factor. Support has no idea how to correct it and has suggested all manner of schedule time offsets and changes but to no improvement.


#2

This is a known limitation of the current rain delay (skip) mechanism used. Unfortunately it puts the controller into a rain delay for other schedules as well if there was any overlap of the non rain skip enabled schedules.

We’ve made a small adjustment to make this less brute force and released this fix tonight.

Previous example:

Schedule A starts at 6:00am and ends at 8:00am
Schedule B starts at 7:00am and ends at 9:00am

If schedule A was skipped unfortunately it would have skipped schedule B since we were setting the rain delay from when we detected the rain delay ~ 5:10am (about 50 minutes before) to the end of schedule A. So, the rain delay was set from 5:10am - 8:00am. This would catch any other schedules and skip them.

Our slight fix to this is we are only setting the rain delay now from when we detected the skip to about 5 minutes after the start of the skipped schedule. This should help you with setting schedules much closer together that are not meant for rain skip. So, in the previous example the new rain delay would be from 5:10am - 6:05am.

As long as you set your schedules that you don’t want affected by rain skip slightly ahead (I’d say 10 minutes for good measure) then they will always run as normal, with no rain skip.

We understand this is less than ideal and somewhat confusing, but it is how the current system is implemented.

We are working towards a much better permanent solution (only skipping the exact schedule).

Please let us know if you have any other questions.

:cheers:


Rain skip question
#3

Hi Franz,

I received your email, i appreciate you investigating the issue.

Thanks for characterizing the logic there and clamping down on the timeframe issue. Knowing the behavior will be immensely useful there. Seeing that is more of a global condition and not a per-schedule attribute, i’ll add the time offset workaround you mention to avoid getting further ensnared in the rain delay net.

Jon