Saturation Skip query

I have an errant valve in my system that sometimes sticks on when using Smart Cycle (sometimes the valve will stick on, causing it to run with another zone). This doesn’t happen when the zone runs by itself so I removed that zone from my regular schedule and created a different schedule for just that zone. I selected all the same Weather Intelligence options for the second schedule. However, it seems that my primary schedule with the majority of my zones will perform Saturation Skips. The single zone, however, doesn’t seem to ever get a Saturation Skip, though it would when it was part of the single schedule.

Is this a bug that a Saturation Skip can only be applied to a single schedule on a given day? Or why might this be happening? I feel I’m overwatering the zone because if the rest of the yard is saturated, this this zone would be also.

Any help quite welcome! Thanks!