Running disabled schedules


#1

I have a few scripts and IFTTT recipes that trigger disabled schedules based on events (temperature etc). I noticed recently that they all stopped working. Are you no longer able to manually trigger disabled schedules using the API?


#2

They should still be working, we will look into this and post when we have more information.

Thanks!

:cheers:


#3

Thanks! What I am doing is trying to trigger a schedule I have setup (but disabled) using schedulerule.start. It when I try and start the schedule using that call it won’t run, so I’ve been starting it based on the zone using zone.start. I’d prefer to be able to start the schedule though. It was working maybe 2-3 weeks ago, and then just stopped.


#4

Ok no problem, we will determine what the issue is.


#5

Can you check the logs for your recipe(s)?

Would like to see if any errors are reported in IFTTT or that the recipe is even running.

I just created a simple recipe, start watering time at 8pm (my watering time is disabled), and it seems to have run ok.

:cheers:


#6

It looks like it’s running OK from IFTTT now, but when I try to invoke it manually using the API it doesn’t run.


#7

Can you PM me the cURL command you are using?

Are there errors you are seeing in the response?

:cheers:


#8

I’m using the rachio python library (updated from github).

When I ran my code again to get the request URI it worked. Was there an issue you found or was it just a fluke and bad timing? :smile:


#9

Haven’t deployed any new code for awhile so odd you were having those issues. Let us know if you notice anything else. Have a good one!

:cheers: