Run / Stop - not working on stop


#1

Not sure why but I’ve never been able to consistently get STOP to work in any zone manually. RUN works all the time. It starts green and comes back green. However STOP only works 1 in 10 times. Even when STOP doesn’t work, the app/communication is still alive as I can set timer to zero and hit run and it works by doing the same as stop (although pump, stops for 2 seconds, starts again for 2 seconds and then actually stops). A run when timer set to zero should equal stop in code please.

Anyway, not urgent as I have the zero-run workaround but a bug for sure.


#2

Hi Frank,

Are you on Android or iOS and may I ask what version of the app you are using?


#3

Same issue. Using Andriod 4.4.2. Latest released version of Rachio.


#4

Ok thanks for pointing this out, we will track this down and get a fix out quickly.


#5

We pushed out a new Android release last night that hopefully addresses this issue. We could not reproduce the defect you are seeing but I understand there are many different types of Android devices. If this issue continues please let me know your exact device so we will be better able to track this down. If you want, you can PM me at franz@rach.io.

Thanks!


#6

Latest release definitely feels much better with cleaner response on the indicators so whatever you did has certainly helped (more testing my end needed to confirm completely).

It would feel “cleaner” if you got an indication immediately it recognized the run or stop was touched. The fact it can be 3-5 seconds before the indicator changes means you don’t know till then if it’s the Rachio that slower to respond or you “missed” the icon. Perhaps a turn the out circle green when pressed and turn the whole button green when confined by Rachio device. Just an idea.


#7

Ok thanks for the feedback, I agree. Will get this incorporated into the next release or a quick patch.

Thanks again.


#8

Using 1.3.2 with a Samsung Galaxy 5 on android 4.4.2, I get the same thing.

Zone setup was fine (can you see sprinkler heads - yes; then they stop), the first time or maybe two times I ran a zone individually, the stop button was enabled, and I was able to stop the zone.

After that, all subsequent times the stop button has been grayed out and I’ve been unable to stop the zone from running.

As an improvement on top of fixing this (and thanks for the workaround above franky_Brit, from a Brit), it would be useful to have some indication of how long left the zone has to run instead/as well as the time you set it to run for.

Cheers.


#9

@jimmyjimjim‌ We had made what we believed were fixes to this issue. We’re looking into it again now.

Also, the run duration should count down on a zone run. We’re looking into that as well.


#10

Ok, just replicated this again(to check what nozzles I had left to change, from the other conversation), and it isn’t quite what the original issue was stated as…but it’s still borked.

I was launching each run from within the zones setup, with the expectation that the countdown timer would appear there (it did once, in minutes, I believe, but it doesn’t now, and the stop control IS still greyed out there).

If, once I’ve set a zone running, I then back out a couple of steps, to the main screen/picture of the Iro, that’s where the timer is. Or isn’t, as it’s still not showing any activity…until I exit the app and go back it, where it spends a few seconds connecting to the Iro then quite happily displays a run time countdown in seconds on the main page.

So it’s a refresh issue on the app.

The stop icon on the main pic still works, but you then have to go into the individual zone control to run for 0 minutes to clear the stop and re-enable to run icon.

And the individual zone stop/start controls are still greyed out (until the time is changed) throughout this.

Cheers.


#11

@jimmyjimjim‌ Thanks a ton for the detailed diagnostic. I think we’ve tracked it down. We will have a fix for this out shortly.


#12

Cool…because I was just using it quite a bit to replace the nozzles and a leaky head, and I was stuffed if I could get the individual zones to fail at all; set to 1 minute, start, stop, repeat several times as necessary, worked perfectly, never had to back out to the main screen at all, or run for 0 seconds.

Great feature, made all of this really easy; it’s a HUGE selling point for the system, as you know.


#13

I have been having similiar issues. trying to use the per zone manual run and stop in the android app . sometimes when I press run, the app will hang and then crash, on nexus 7 tablet running 4.4.4and my Galaxy S3, once I restart the app I can run the zone but stop button gets grayed, cont control the zone anymore.


#14

Our next release (1.5, Android being released this week) has some fixes around our messaging connectivity. When the app goes in the background there are certain situations where we were not reconnecting. If these fixes do not solve the issue please let us know. I will post on the forums when 1.5 is released and we will be sending an email out to the community.

Thanks!