Rachio with Alexa is not working correctly


#1

I have been using this Rachio Gen 2, with my phone and it is working great.
Now I have an Amazon Dot, and I’m trying to integrate it, with Rachio.
I have enabled the the skill in Alexa app.
What I’m noticing, is that the skill, when is done, is not searching for new devices.
I send the voice command and Rachio app shows that is watering.
My problem is, that is not actually watering, just the app shows that it does.
Phone, Rachio and Alexa, are on the same 2.4Ghz band.
Any help, would be appreciated.

Tibor


#2

Hey @tibimakai-

Is your system able to run correctly from the app? It almost sounds as if something is wrong with your connectivity in general.

McKynzee :rachio:


#3

Yes, it is working great from my phone.
I will give it another try this weekend.


#4

Let me know how it goes!


#5

What I’m noticing, in the Alexa app, that when the skill is added, it won’t tell me, to close this page to start discovery.
If I click on discover devices, it won’t find the Rachio controller.
Also, if I try in the Alexa app, the Smart Home/Devices, Rachio is not in the list. I have a Living room lamp(TP-Link smart plug) and my Honeywell thermostat in the list, but Rachio does not show up, no matter what I try.
Even if I’m next to the controller with my phone, it won’t discover it.
Everything is set on, the 2.4Ghz band(I also have the 5GHz band). I have an Asus RT-AC3100 router, with Merlin firmware.
Rachio controller, works great otherwise. So, it can’t be the wi-fi signal.
To me, it seems like, there is something wrong, in the Alexa app.


#6

I have the EXACT same problem as tib… how come there hasn’t been an answer for this in 2 months? Asus 5300 on 2.4 ghz band stock FW, TP link plugs and nests show up fine, but Rachio (and even harmony) are not discoverables (even though accounts are linked)


#7

To tell you the truth, I have forgot how did I fix it, but sometimes, it is a good idea to reboot the phone, or if you have an Android phone, kill the app and restart it.
I’m using Smartthings, by the way.


#8

@tibimakai Are you discovering it within SmartThings? There is no actual LAN discovery going on with either our direct integration or the SmartThings integration, so the network would actually have nothing to do with it unless you have low signal on your phone and it’s not communicating with our servers. I also have both Rachio and an extensive SmartThings setup. It sounds like you were able to figure it out and get it working though?

@Aradia1989 Are you doing the connection to Alexa through SmartThings also or is it direct to Rachio? Are you following the steps in This Article? There shouldn’t be a discovery but rather a linking using your Rachio account.


#9

Thanks, but for now, the Rachio is not the priority for me. I’m having other issues, like Schlage Connect door lock opens by itself…
I’m wondering, in which order should be set up all of these devices, hubs and of course, Alexa.
I have the Smartthings hub, Logitech Hub, Philips Hue hub, Rachio, Philips hue LED bulbs/Strips/switch, Schlage door locks(2)? I have the Amazon Echo Dot + remote, as well.


#10

It sounds like you’re experiencing some trouble getting everything all set up? Did you decide to jump in full throttle on a Smart Home? Over the past few years, I’ve gathered a SmartThings hub with 100+ Zigbee and Z-Wave devices, WeMo, Hue, Quirky Aros A/C, Bose SoundTouch, Samsung SmartCams, Google Home Mini, Amazon Echo Dot, Nucleus Intercoms and of course Rachio.

Your best bet for setting up would be to get each individual WiFi/LAN device connect.

  1. Start with your SmartThings hub and connect all Local Devices (Zigbee and Z-Wave). This will include your Schlage lock. I highly suggest bringing your Schlage door lock as close as possible to your SmartThings hub when connecting that.
  2. Set up your Logitech Hub, Hue Bridge and bulbs, Rachio and Amazon Echo Dot.
  3. Connect your Rachio to the Amazon Echo dot following The instructions in this article.
  4. Connect your Logitech Hub and your Hue Bridge and bulbs to your Amazon Echo account also.
  5. Finally, if you want all this in your SmartThings account, you can connect everything you have to it. Then you can connect your SmartThings account to the Amazon Echo.

I know SmartThings support is always happy to help if you run into any trouble during setup.

Hope this helps!


#11

Thank you for your help. I will have to start from scratch and than see how everything works.
Yes, I’m all into making my home smart.
In Alexa app, I have all my Hue lights doubled. It’s a mess.


#12

Hey no problem - I love Home automation :slight_smile: but yeah it can become a mess. If I were you, I’d connect your devices directly to the Alexa and not through SmartThing to the Alexa. Although I have my Hue bulbs connected to Alexa through SmartThings because I like all my lighting through ST. But things like my Rachio and Harmony, I’d do a direct connection.

However, do what you feel works best for you. You can always connect them directly to Alexa & through SmartThings to Alexa and just remove the SmartThings side duplicates within the Alexa app.


#13

Hi, I’m new to the community from Canada. I don’t see the Alexa skill as an option for Rachio. Will this be enabled for Canada? I have several Alexa speakers and would love to be able to use them with my Rachio controller. I’m using iOS from my iPad to search for the skill.

Many thanks


#14

I’m having the same problem with the Rachio not showing up in my Alexa app. I have enabled it and I can give it voice commands. But the Alexa app can’t find the controller to add to my Smart Home menu. Any advice?

Thanks!

Brad