Rachio website calendar is way off

When I log into my Rachio (today is 8/10) via the website on my computer I get this really messed up calendar on the home tab at the top of the page. Everything in the app appears fine. Is this something that others are seeing? Thanks.

1 Like

Try sliding it to the right to show earlier dates. (If that makes sense)

I see the same thing DrChops sees. MacBook, current OS.

1 Like

Going to the right is just as messed up with 8/19 and 8/21 to the right of Today. None of the dates are in any kind of logical order.

its a mess here as well

1 Like

Been a documented problem with the web app for quite a while. Have you tried refreshing the web page? Sometimes that fixes it. Anytime I get something odd from the app, I refresh. In most, but not all, cases that fixes it.

Tried refreshing and logging out and back in but it is still a hot mess. I love the phone app but the web site/app is terrible. A black eye on an otherwise great product.

I have the same problem.

Same thing is happening to me. I also ran a test using Edge, Chrome and Firefox, the dates are out of order. In the app it looks good.
Click below link for a quick video that I recorded.


I’m using Chrome on a Mac running Monterrey. Went to my Rachio tab and it looked like this. Did a refresh and it corrected itself.

Like @Linn said earlier, this is a known documented issue with the web UI. I have no idea if the web UI is still slated to be chopped, but that might explain why they haven’t jumped on fixing it like they do with other things that pop up.

Yeah same problem on latest Windows google chrome version. Calendar/forecast days are all out of order. Refreshing doesn’t fix it for me either. Seems it wouldn’t be too difficult of a fix really.

I hope they do not chop it. Personally, I hate using my phone only. If it comes down to having a messed calendar on the website or no website. I can deal with the mess. :slightly_smiling_face:

While discussing this, does anyone know where this Weather Forecast Data comes from ? It certainly does not match the forecase on my PWS