Rachio GenII and Linksys Trendnet TEW-632BRP


#1

Admins, please move this if it’s in the wrong place.

Had a problem getting my Rachio to connect. It kept stopping at the third blinking light. Tech support was helpful and we tried several things, but it all boiled down to the Rachio was not connecting to the cloud. Finally I used a MiFi just to see if it was my ISP or Wi-Fi router. The MiFi hooked right up so it was down to my network or ISP.

Yes, my Wi-Fi router is “old” but it isn’t like the protocols have changed.

One thing I noticed was my tablet/phone stayed connected to the Rachio’s WiFi while the Rachio is trying to connect to the cloud. So I turned the tablet wifi off when it says that and power cycled (rebooted) the Rachio. After rebooting the Rachio connects and works fine.

TEW-632BRP settings (not all of them, just the key ones)

  • Wireless/Basic
    Mode - Mixed 802.11n, 802.11g, and 802.11b (I tested b, bg, and bgn. all worked)
    Channel Width - Auto 20/40
    SSID Broadcast - Disabled (both enabled and disabled work. Enabling makes things a bit easier.)

  • DHCP
    I set up the router to give a static IP to the Rachio based on the MAC address.
    Static IPs seem to cause less problems with “cloud” thingies. That and it is easier to set up firewall rules (below) with static IPs.

  • Wireless / Security
    Authentication Type - WPA2 PSK/EAP - PSK
    Cipher Type - Auto
    Passphrase - see below

note: Max for WPA2 is 63 characters, though tech support said they have had problems with >20 characters. I am just using a-z 1-0 as my character set.

Tested up to 15 characters. Got tired and stopped there.

Now for the Firewall settings.
My settings are “secure” so it’s a default Deny. If you have this type of security you will need to poke a hole for the Rachio. If you have a MAC address filtering you will also need to add the Rachio’s MAC address to the Allow table.

Opened up both outbound and inbound. I may tighten the protocols down later.

Action Name       Source             Destination        Protocol
Allow  rachio-out LAN,192.168.10.116 WAN,*              Any,*
Allow  rachio-in  WAN,*              LAN,192.168.10.116 Any,*

192.168.10.116 is the static IP for my Rachio


#2

@DougW Awesome, thanks for sharing!

:cheers: