Rachio Gen3 does not like WiFi special characters or long passwords

When I first tried to connect our Rachio Gen3 to our WiFi, I tried 4 times and each time it seems to be connecting but would get stuck at the last step. I think it was a while light going around and around non stop. Finally I thought maybe it does not like our password. That password is 40 characters long and includes special characters “[]<>”.

Sure enough once I tried our guest account which is 17 character and has no special characters It connected to our WiFi right away.

The WiFi is a triple-band Nighthawk R9700P firmware V1.4.1.30_1.2.26 and the wifi configurations are WPA2-PSK [AES]. The Rachio now has firmware ir03-firmware-hk-5-615.

I don’t want to use our guest account and I like our secure regular password. Will you be able to fix the Rachio hopefully through a firmware update?


Not questioning your security practices but wow. That’s an impressive WiFi password. A quick google shows the character limit is 63. Interesting finding. Is it definitively special characters or password length or a combination that Rachio appears to hiccup on?

The two WiFi accounts both come from the same router so what else would the problem be? Maybe the Rachio does not Like multi-band routers and only likes the single band guest account? Who knows, but all these things are standards. It is a standard 802.11ac router.

The Rachio people should be able to reproduce this problem. I am happy to give you guys any other info you like.

Could be multiband router using the same SSID for 2.4ghz and 5ghz. My older router is terrible at band steering so I keep the SSIDs distinct, otherwise my phones hang on to 5ghz for dear life and act like all is well despite losing network access. Having an Internet of Things device on a guest network isn’t the worst thing in the world, security-wise. But may have implications for usability of HomeKit or other smart systems.

Good points.

For me it is more about stability. I consider the Guest password disposable.

Yeah that’s not ideal for IoT devices but definitely a prudent practice. Maybe have another guest network only for IoT and not guests (if router is capable).

Hopefully there’s a way to connect the device to the main network for simplicity & stability. But some devices just have a hard time with dual-band same SSID, for whatever reason. My roomba for instance!

Yes it could be the dual-band same SSID or tri-signal in the two bands. Hopefully the Rachio people will look into this.

Thanks for sharing, @dgp thoughts on password length and gen3?


Were you trying to on board with iOS or Android? The two systems are separate so it’s possible one will work when the other doesn’t.

Hi, thanks for looking into this. I was going through a first time connection using an iPhone. It went through all steps normally except what looked like the very last step which would never finish.

Guest accounts are often 2.4 mhz while main wifi is 5mhz. Some devices need to hook up to 2.4mhz wifi. I have not checked the requirements, but could be an issue. The Gen 3 is dual band and can connect to either speed.

While slower, a 2.4mhz signal is less susceptible to building interference since its waves are more than twice as long as 5mhz… Both work well but that may be a reason why it is easier to connect on 2.4 than 5 mhz for some people.

One time when I was having to reset mine up due to a new wifi password, it failed several time and then worked fine. I chalked it up to being on the edge of a strong enough wifi signal.

I’m having a very difficult time hockey my unit up to Wi-Fi. I restarted my network and done the process several times no luck.

@Legarde - what mobile operating system are you using (Android or iOS)? iOS seems to work more reliably.

Any mesh network (eero, or orbi)? Extenders? What band is being used (2.4 or 5 GHz)?

Which WiFi channel is the router using (a non-US router has other channels that Rachio can’t connect to)?