Rachio gen 2 will not connect on any 2.4GHz networks with any mobile device


#1

I tried everything Dane B. suggested below, on multiple 2.4GHz networks on 2 different Android devices. A Rachio gen 2, less than 1-year old, that worked at the end of last season is now a brick and cannot connect to any wifi network. It worked fine at the end of last season. What gives, Rachio? I did the AddThis diagnostic, sent you the code, and everything. What else do you need from me? Very, very frustrated over here.

Dane B. (Rachio)

May 14, 9:03 AM MDT

I’m glad you reached out to us regarding the issues that you are having connecting online. We identified an issue with our app’s WiFi connection on Android 9 devices.

We apologize for the inconvenience, but I am happy to say that our engineers have resolved the issue. Please go to the Google Play Store and ensure that you have the latest version of the app. Then, attempt a WiFi update outlined here.

Please let me know if you have any further questions or concerns or this response did not address your issue.

Best,

Dane B.
CX Supervisor
Rachio Support
Rachio Support Hours
8 a.m. - 5 p.m. MST
Monday - Sunday


#2

Can you share the diagnostic code?

What error are you experiencing?

Have you tried an iPhone?

Have you performed a WiFi reset?

:cheers:


#3

The diagnostic code is 5T9YSZQ6

The error I get is the “Oops! Can’t connect to wifi”.

I do not own an iPhone. I was not aware this was a requirement since Android worked fine last season.

I’ve reset my wifi. I’ve reset my Rachio. I’ve reinstalled the Rachio app 2x. I’ve reset everything I can think of. I’ve turned off all wifi security. It still fails.

Thanks for your help.


#4

Other information:

MODEL: 8ZULW-B

Appears to be produced August 2017. However, I bought it from Home Depot approximately last July.


#5

OK I will have the team review the diagnostic code.

Are you on the latest version of the Rachio Android app? The build number is 13137.


#6

I had the team review and it looks like you are on an older version of the Rachio app.

Please upgrade that first and try re-pairing the controller by first doing a WiFi reset. Hopefully that will resolve your issue.

Next, if that doesn’t work, from the diagnostics code it looks like you have a range extender. I would try to get on the router network first (2.4g network) and bypass the extender to verify that you can connect directly to the router.


#7

I am having a similar issue. When I first installed my Rachio Gen 2 with our old internet it had no problems. Today I tried connecting it to the new network and it gave me the same “Oops! Can’t connect to wifi” I reset everything and after 2 hours of trying it I gave up. I see my app on my android got updated yesterday.


#8

Franz, please find a screenshot of the app as I had it installed when I ran the test. I am not sure what you mean. It says 13137 v3.14. I am actually not on a range extender. The network that I am connected to is the router network (2.4GHz) on the actual modem appliance given to my by Xfinity. I turned off my phone’s LTE and ensured that in airplane mode, the only network showing is the Xfinity router’s wifi. I’ll reset everything and reinstall the app one last time. However, if it fails again, I think that it would be considerate for Rachio to help me test another device. I’d kindly mail this one back to you. I’ll get back to you with the results shortly.


#9

@jj2 and @dcostales - late to the party here. Can you try reserving a DHCP address on the router for the Rachio device and see if that solves the problem?

What are the light codes you’re seeing in the failure mode?

iOS devices aren’t a requirement, I’ve just seen that iOS seems to handle networking issues better on the setup.


#10

Can you try again? Our engineering team is saying the last provision you tried was with the older Android version.

Thanks!

:cheers:


#11

@DLane it think this is getting too technical and instead of working as it fine worked the first time I don’t want to start doing all these extra steps.


#12

@dcostales Bumping this…it might just be the app version you are using…Can you please try again using the version of the Rachio app you just shared? Thanks.

:cheers:

Rachio gen 2 will not connect on any 2.4GHz networks with any mobile device


#13

This attached is what I currently have on my phone. I’ll uninstall and reinstall the app to see what happens.


#14

I got it to work by restarting my phone. In the end, although I had the latest version of your app (or so it said), it did not work until a phone restart. It had nothing to do with any other setting, be it network, router, wifi, you name it. That was irrelevant. The update you performed today, May 14, to the Android app + a phone reset is what fixed the issue. For anyone else with these issues take note: do not go about resetting everything on your home wifi setup to oblige this problem. It is most likely your phone app + needing a restart.

There are several hours of my life I’d like back :wink: I hope this helps somebody else. Too bad you’re not like Xfinity or I’d feel entitled to ask for at least a statement credit :stuck_out_tongue:


Rachio Gen 3 unable to connect to WiFi
#15

@jj2 Thanks for your patience, and sorry about the confusion. As soon as we started hearing about these issues with Android 9 and our app we rushed a fix out. Unfortunately it sounds like you were caught right before the update came out. I hope you have another great watering season and have a great week.

:cheers:


#16

Thanks. Naturally, I understand that issues like this come-up. That said, one future idea for your Product team would be to have a way to proactively PUSH notifications to customers using your app (even if the dated version) so they know a fix is underway. A tiny dose of communication and a statement of “we’re on it, patch coming soon, known issue!” would be SO much better. There are great ways to push directly from your own app, and if I’m not mistaken you could also send an email or SMS to users in cases where you know they’re running your app on a certain platform (since we do login to your app).


#17

(At least I would have likely not messed up my entire home network and disrupted every other device in my house in the meantime!)


#18

Mine is good to go now as well. I realized my app got updated around 8pm last night so when I tried it early in the morning I was with the old version. I restarted my phone today and ran the steps and I’m ready to water our lawn :slight_smile:


#19

Awesome, thanks for your patience!

:cheers:


#20

Hey @franz,

This is in reference to # 628622 via email that I had reached about my Gen2 suddenly going offline. My landscaper had just turned on the water for our sprinkler last week and when I checked my Rachio unit the other day, I noticed it was offline. Did the whole reset/troubleshooting for the Wi-Fi part but nothing seemed to work.

Did something happened on the back end?

My app (Android) is 3.14.2 (13170).

Thanks,
David