Rachio gen 2 setup problem

i just got one and trying to set it up. i followed the steps listed in the app and manual.

when the 2nd led was blinking, i scan the barcode and connect it to my 2.4g wifi (phone was connected there as well, and was working fine)

it says updating firmware, after that it’s trying to add the controller to my wifi, and then says oops couldn’t connect to controller

during that process, the 3rd led was blinking, and then went back to 2nd led… this keeps happening until now (1 hour later), even though i’m not doing anything on the app.

how can i make it work?

Can you try running this against your network and provide the generated code? I will have the engineering team review.

:cheers:

I did yesterday/2 days ago. The codes is qhw7wmjq

Fyi my rachio’s serial# is vr0648835

Network looks standard, had Android team review your account and do not see anything in our logs.

Do you happen to have any iOS devices to try pairing the unit?

:cheers:

no ios… only android and windows pc…

From your routethis scan we can see your controller is connected to your wifi network so the issue seems to be getting your controller connected to our server.
If possible can you reset the controller and try onboarding again? The app should send us a log of your onboarding with some details of why it failed but we can’t find a report from your account yet.

1 Like

actually i did last night, several times… i restarted my router, factory-reset the controller, and still didn’t work

anyway since i retried the onboarding last night, do you have the log now?

thanks

Thanks for trying again. The logs from your app came through this time.

This seems to be the problem:

Your network uses IPs with the format 192.168.10.x. Unfortunately the controller during onboarding also uses 192.168.10.x for the IP address it uses to talk to the Android phone directly. So when the controller gets onto your wifi and tries to connect to our server it is probably trying to use the connection to the phone and not the wifi connection with internet access and is failing.
Going into your router and changing the range it uses in the DHCP settings from 192.168.10.x to something else like 192.168.0.x, 192.168.1.x… will resolve the issues I think.

Thanks,

Daniel

1 Like

Questions before i make this drastic IP change:

  • Is this only on Android?
  • Is this only needed during setup?

If IOS don’t have this restriction, I can try borrowing my friend’s IOS just to set it up. After the controller is set up, I assume it doesn’t need to connect directly to my phone anymore, right? (like other IOT devces I have, I assume the connection will be either via cloud our LAN).

This will affect iOS too as it uses the same direct connection to the phone but I think iOS shuts down the phone connection before the app tries to assign the controller to your account and that might let it get online.

It’s only needed during setup. This might be a better solution if you have another android phone around:

  • Turn off your access point.
  • Configure a phone’s mobile tethering to use the same network name and password.
  • Configure the gen2 using that and after it’s successfully connected turn it off.
  • Disable the mobile tethering.
  • Turn the access point back on.
  • Power up the gen2.
  • The gen2 should connect to the normal access point and come online.
2 Likes