Rachio down after Eero installation

I installed an Eero this week. Rachio seemed fine although I had to re-add it to HomeKit. Today the controller is offline. The only thing I changed was that I added the Eero to HomeKit too this week which is supposed to be a good security feature. Could that have taken my Rachio offline? I did a WiFi reset and I also did a troubleshooting in the rachio app. No dice. Help!

If you run this and provide the generated code I can have the engineering team review your network setup.


Ok will do. Is it possible that it’s because I added Eero as a HomeKit router and that adds a layer of security that blocks the Rachio connection?

I don’t know if that was the issue.


It’s possible. I’d go to the Home app and put no restrictions on Rachio. You may need to power cycle Rachio & reboot eero (only if power cycling Rachio after changing that setting doesn’t help) after doing that. Rachio relies on internet access so don’t restrict it in any way. Don’t use the automatic setting, use only no restriction.

1 Like

Ok I used the route this app

You’ll need to provide the Route This code. Also did you try setting Rachio to not restricted as described in my post above? That’s the first thing I’d do since that’s what changed on your network and seems to have caused problems.


Did the code not get uploaded automatically? After I ran the route this test, it didn’t provide me with anything.

I removed my Eero from HomeKit and it fixed the issue. I imagine that rachio will see this issue again as more Apple users add an Eero connected Rachio device to HomeKit.

1 Like

Glad that resolved the issue. If you try HomeKit router again, try putting Rachio on No restrictions at HomeKit router/HomeKit device setup. That way you can benefit from HomeKit router with other devices. I like blocking my ecobee from the Internet since it doesn’t need it to function… I’m somewhat afraid of the Eco+ feature update that is slowly rolling out…

1 Like

I have not been able to get my Rachio 3 working with my Eeros. (I have tried all of the tips and tricks BTW) I have the HomeKit feature in Eero turned off. Can you answer a couple of questions about your setup?

  1. How many Eeros do you run in your network?
  2. How many HomeKit hubs do you have?

I’m trying to understand what might be the difference that is hosing HomeKit for me on my Rachio. One thought is if someone has a single Eero, it might be a factor. The other thought is how many HomeKit hubs because when I get glimpses of my Rachio showing on the Home App, sometimes I see the actual zone names and sometimes I see Just Zone 1, Zone 2, etc. I’m wondering if multiple hubs are creating an issue.