Rachio 3 won't connect to eero 6

I have eero 6 mesh network and just bought rachio 3rd gen
No matter what I do cannot get past the yellow flashing light (unexpected error, having trouble connecting etc). I have more than 20 other devices on the eero and every one connected with zero hassle!
I have rebooted unit, rebooted network, set up another extender with different network name to see if would log onto that, etc but nothing works
Does rachio work with eero 6??

Have you tried eero’s Legacy mode?

See this eero Support article:

Thanks for the tip. I also found another article that says newer iphones have trouble connecting. So I found an older ipad, removed the Rachio controller, then added it back and hey presto it worked! It seems like somewhere Rachio should post that it doesn’t work with new iphone/android at least with firmware it comes loaded with. These phones aren’t exactly new - I’m sure I have had mine a year or more.
I then tried to update firmware but after 3 attempts gave up. Still, it works sprinklers with old firmware so I’ll settle for that for time being

1 Like