Rachio 3 won't complete setup

If a unit was previously set under another user will this cause an issue? I purchased what was described as an “open box” rachio 3, manufactured in June 2019, from ebay to help save the planet from producing another one :wink:
Regardless, I am technical if that matters working in info security and networking so pretty good chops on me from that side.
The distance to my router isn’t substantial, and I have a FLume bridge set up in the same location (though it is OFF to avoid any issues there) that on 2.4 works fine, my sonos also in garage works fine (also OFF), and phone, etc. etc.
I have tried:
2.4 ghz network
5 ghz network
Factory reset
Resetting the wifi numerous times
Running it from an android phone
Running it from an iphone…

It will make it through the setup and when it gets to the part of “Waiting for the device to become active…” it will wait around 3 minutes and that’s it.

Great. So it shouldn’t be hard to find out what is going wrong, though if it’s internal to the device it may be hard or impossible to fix.

Given that you have two phones, I would first rule out anything with your network by temporarily setting up one phone as a mobile hotspot. Confirm that it’s working by connecting from the other phone and accessing an internet site. Then, reset the Wi-Fi on the Rachio and try to set it up on the temporary hotspot. If that is successful, we can suggest a few simple tests to see why your regular network isn’t passing the Rachio’s traffic. If it fails, report what error you get.

Strange. I actually did nothing. Went to dinner, came back, blue light was on and everything works fine.

“It’s Christmas, Theo, it’s the time of miracles”
-Hans Gruber