Rachio 3 will not connect to wifi

Just installed the Rachio 3 today but cannot get it to connect to wifi. Ran setup 3 times on my Android 9 phone and once on my wife’s iPhone X.

I’m using a Tenda Nova mesh wifi network.
2.4 & 5ghz
Same SSID on both networks, and they cannot be changed.
Tenda Nova firmware is the latest version.

I moved one of the nodes within about 12 feet of the Rachio 3 and I still cannot connect. The wifi nodes have “excellent” signal between each other.

RouteThis code: 5UJZEQRR

Nevermind, I’m returning it. Leaving this post up for posterity.

I’m sorry that you feel that way. We can likely get it working with less effort than it would take to return it.

I believe that your first post was ignored because although you described your network in detail, there was no diagnostic info present.

What do you observe on the controller, e.g. second quadrant blinking but remains in that state after attempt to provision?

What error messages do you see in the app? Same on Android and iOS?

What troubleshooting steps did you take, e.g. “I set up a mobile hotspot and tried to connect the controller to it, but received the same error messages”?

Did you try the Smart Assistant function on the Tenda?

Can you get the controller into the state where quadrant 2 is blinking?

If so, can you see its Rachio-xxxxxx network on your mobile device?

If so, can you connect to that network (of course, there will be no internet access)?

If so, can you remain connected for at least two minutes?

If so, can you open in your browser and see the expected ‘not found’ error?