Rachio 3 power cycling repeatedly

My Rachio 3 has been power cycling constantly. Sometimes 10-20 times a day and multiple times just minutes apart.

Support has been great, but their only solution has been to send me a new device and power adapter. So far they’ve sent me 3 replacement units:

  • I replaced my original unit with a new one. Same issue.
  • Contacted support, they sent me another new unit. Same issue.
  • Contacted support again and they’ve now sent me a THIRD unit.
  • After I contacted support on the second unit, suddenly the power cycling stopped for 4-5 days. (Not sure what happened.)
  • I now replaced just the power adapter and now I’m getting power cycles again. Between 4-5 per day to as many as 20 a day. Many just minutes apart.

Seeing comments in other threads, I’m thinking it may not be the power adapter. (I’ve also tried plugging the Rachio in to a completely different circuit with a 50 foot extension cord. Same issue.)

I’ve read that there may be an issue with the firmware related to how it’s connecting to wifi that could cause this behavior.

I read another thread that said there could be a firmware update that could solve it. But the thread was from 2021, and I just bought my unit earlier this year (2024), so I would think this would have the most up to date firmware.

As for my wifi setup, I have an Eero mesh router system with 3 Eero Pro 6 units. There are two that the Rachio could be picking up. One upstairs about 30 feet away and the other on the lower level probably 20 feet away.

Has anyone seen issues like this and been able to solve it either with firmware upgrade or changes to my router configuration?


I have very similar issues - except the controller just shuts down - it does not reboot.
I have a mesh network as well. I noticed the controller started crashing when I moved a satellite ( I have an ORBI network) around so it was closer to the controller. I am absolutely convinced the wi-fi subsystem has a serious bug that actually crashes the whole controller operating system.

And support sent me a new controller as well - they keep blaming the power supply. It’s not the power supply. They need to get that through their heads - it’s a software issue.

You could try giving the controller a fixed IP in the network DHCP setup of Eero.

1 Like

Did you try the fixed IP idea with yours?
Did it solve the problem?

It did for a while…like a year. Until I moved one of my mesh network satellites closer to the controller to fix a dead spot in my house. Then it started all over again. I now have a Wi-Fi switch that I program to cycle the power on the controller once a day just before watering cycles would start. Obviously your problem is worse than mine. It’s maybe worth a try to assign the IP in DHCP settings.

Oh wow! Sorry to hear that!
Over the last few days, it’s stopped power cycling as much. It’s now just doing it 1-3 times a day which is much better and may be tolerable. At least when ours power cycles, it seems to just power down and come right back online.
Thanks for your ideas! I’ll continue to watch it. If it gets worse again, I’ll try some of your ideas.

@ChipRodgers and @loopless : I am having very similar issue. My Rachio3 keeps dropping off the network and doesn’t connect to the network automatically. I have to go to my WiFi setting on the phone and manually add Rachio to the network. (I figured this out one this, but until now I used to go to the until and used Rachio’s Troubleshooting wizard, which did the same thing in a long wounded way and forced me to be there physically at the unit). I like the wireless functionality of the unit, but only if the damn thing stays connected. I tried running RouteThis app as per the support, but they couldn’t figure out anything. I upgraded my network to Mesh and configured it to be associated with the closest unit for a strong signal. This is the only device in my network which keeps dropping off like 10 times in a day. Now that you have mentioned, I’ll have to check if it’s power cycling or just the network part is messed up. I’ll also check out assigning IP instead of DHCP, but this is just so out of line for a IOT device. If you have anything else, I could try please advise.

The RouteThis app is pretty useless. It’s just checking you have a decent Wi-Fi signal. Which can be accomplished by looking at your Wi-Fi bars in your iPhone while standing near the device. The problems I have do seem related to how the device connects to a Wi-Fi network, and for whatever reason it struggles with a mesh network with multiple stations. Try assigning a static address using dhcp.

I have mesh network by tp-link (Deco) and there is a way to hardcode and assign it to one of the nodes. I’ve also assigned a static IP to Rachio3. Let’s see how it goes.

Update us on whether it works!