Rachio 3 not connecting to WiFi - DNS

Hello,

I’ve been searching for a long time now, and really at a loss. I had my rachio 3 setup (which I got recently) and it worked fine. I had to disconnect it for a few days, while I was moving stuff around in my garage. When I connected it back today, Rachio just refuses to connect to the internet. The light blinks int he 3rd quadrant. I’ve tried troubleshooting, I’ve also opened a ticket with support.

Things I’ve tried:

  1. Connected to Rachio using my Android phone.
  2. Use Android as hotspot and connect to rachio from my laptop (mac).
  3. Run the following command: curl -k -X GET -H “x-api-key: AC5037641” -H “Content-Type: application/json” “https://192.168.0.1/conn
  4. Response: {“con_state”:{“current”:“WIFI_CONNECTED”,“furthest”:“DNS_FAILURE”,“code”:0}}

This kind of matches with what I see in the controller, the light flases white for a while and then a red flash (3rd quadrant). I looked up online and found an old post talking about rachio trying to do a DNS lookup and failing. What is the endpoint rachio needs to connect to? Is it mqtt.rachio.io? I tried doing a nslookup or ping for that host, and I get nothing. What can I do to from this point onwards?

Please help.

My Rachio 2 looks up pool.ntp.org, gets the time, then looks up mqtt.rach.io. The DNS server is whatever the DHCP server sent. The gen 3 might be different. Can you capture traffic at your router to see what it’s trying? mqtt.rachio.io appears not to exist.

Hi was able to get it connected back up.

Resetting wifi did not work.

I had to hard reset the controller (Pressed the stop button for a few seconds).
Tried connecting to my 2.4Ghz wifi and it did not work, tried again with the 5Ghz network, and that seemed to work. Had to reset all my zones and everything. But at least I got it to work. Cheers!

That should not have been necessary. Should this happen again, use Option 2 (Controller reset using the buttons on the controller) and skip step 3.

rachioJ,

Yes, you answered your own problem with the stop button.

Once connected you can ask customer service to refresh your Zone settings so you dont have to reconfigure. Sometimes works and sometimes not.