Rachio 3 - iPhone 13 Pro IOS 16.2 - won't connect

I had my Rachio 3 installed this past weekend and tried to connect it to the app. This is apparently an ongoing, long-term issue with the Rachio app based on several other posts over the past several years - since at least 2018, and it’s now 4/4/2023. Why is this issue persisting? Why has Rachio not fully resolved this connection issue? Two of us tried repeatedly to set it up on our different iPhones (I don’t remember what version she had - I think iPhone 11) and neither could get it to connect. I can see the Rachio network under WiFi on my phone, but cannot get the Rachio to join my network. I have a LOT of experience with home automation set up. I have multiple light switches, multiple door locks, a security camera, a doorbell camera, a Litter Robot, and two robot vacuums all set up to the internet via apps and none have been problematic to connect to the internet. Rachio needs to FIX this problem. We should not have to force-add the Rachio to our network using a wifi-enabled computer. I have not tried this option yet as I normally use a hard-wired desktop at home, but I will have to get out my laptop and see if I can get it to work that way. But OMG, I should not have to do that!!! If there is a current fix beyond the force-add through the cURL commands, please someone tell me what it is! I have searched through multiple posts here but can’t seem to find a current one regarding this issue.

You should be able to get it to connect, but I’m a little unclear on some of the steps your taking, so I may be able to help a bit better with a couple more details.

You say here:

Two of us tried repeatedly to set it up on our different iPhones (I don’t remember what version she had - I think iPhone 11) and neither could get it to connect. I can see the Rachio network under WiFi on my phone, but cannot get the Rachio to join my network.

  1. How are you trying to get it to connect?
    a. Are you trying to add a new controller to your account, or reconnect an existing controller?
    b. Based on this, are you using the app to attempt to add / reconnect? Or are you going into iOS Settings → Tapping the Rachio network you see in there?
  2. Depending on if the Rachio is already added to your account or not, going through iOS settings may not help. It can be used for reconnecting with an existing set up, but if setting up new, it won’t work.

Thanks for providing clarity on any of these that you can.

It is an initial setup of a new Rachio 3 (sorry, thought that was obvious). I am following all steps within the app to the T. It gets to the point where it’s trying to “add accessory,” takes about 2 mins of waiting, then says something like, “oops! Can’t connect to your device,” and then says the Rachio is not connected to my network. I made sure I was on the same wifi network as the one I was trying to connect to, I can see the Rachio under “Wifi” as a network. and the rachio shows in my app. But it has never actually connected. Now I go into the app and click on the Rachio and it says “We had a problem loading your data. . . .” I keep getting sent in circles by the app. Some messages say the Rachio is not connected to my network, others say it can’t access my data, and there’s a couple of other error messages or info given. The only option I see is to try the force add but I have to get my new laptop operating to do that. Such a ridiculous mess. This should not even be an issue after all these years.

Sharon E. Conway

Please forgive my typos, as this e-mail is sent from my iPhone.

Thanks for the details. Taking a deeper look it seems your Rachio has an old version of firmware. The version it has on there is one that experienced an issue with getting set up via the application. Newer versions of firmware have this issue fixed. What we’ll try doing now is getting your controller online so it can get that update and work as expected.

I see a device already on your account. Is that the same one you’re having issues with? Just making sure as the troubleshooting steps we try next will assume it is. If not though, let me know and I can update the message.

  1. You can try using your iPhone to get online, via iOS settings. You mentioned that you can see the Rachio Network under WiFi. If you tap that Rachio network it’ll start what’s called accessory configuration. This may not work though, as in iOS 13.4.0 Apple made an update to iOS that caused the issue with our firmware. So if this does not work, one of the other solutions should. And given this hasn’t worked before, I don’t anticipate iOS working.
  2. If you have a Mac computer, you can do the same thing as above. In the WiFi selection you can configure a device. Macs never got the update that caused issues with the iOS update. So this process is a pretty seamless replacement. But only applies if you have a Mac computer unfortunately.
  3. Using another device has a bit more work. We outlined the steps here Rachio 3 WiFi Troubleshooting: Quadrant 2 Flashing Yellow. This part here is not ideal and I apologize for that, but with that older version of firmware that is susceptible to the issue, another device is the only way to get it online to get the firmware update that fixes this.

Thanks. I will be trying the cURL force-add as soon as I get my laptop set up. The Rachio was a gift from my Realtor when we closed on this house 3.5 years ago, so it is a bit older. I have already tried the stuff in your #1 and of course it did not work.

I don’t have a Mac, but my kiddo has an Android phone. Would it work to try and set it up through his phone? If I got it to work, would I then be able to access it via the app on my iPhone?

Sharon E. Conway

Please forgive my typos, as this e-mail is sent from my iPhone.

Yeah, if you have the ability to use an Android device, that connects the Rachio to your network in a different way that is unaffected by the issue. That will probably be the easiest. And if you’re using that on the Rachio that is already added to your account, you’ll be able to just go through the Update WiFi flow which will get your device online. That may be a bit easier than some other options.

I just wanted to call out the slight difference of attempting to re-add the controller to your account if it already exists on your account, and updating the network of a device that is already on your account. If you attempt to go through the “Add new device” flow and this device is already on your account, you’ll get an error message telling you the device is already on your account.

But you can update WiFi by going from your Controller Home tab > More > Controller Settings > Update Wi-Fi Network and follow the steps provided. If you do that from the Android device, you should be online and set up. Once online, the controller will update its firmware automatically after some time.

I’m not trying to be annoying. But I am running a Rachio 3 on my iPhone 13 Pro, running 16.4.1 and I have no problems whatsoever. Just make sure you are trying to connect to a 2.4 GHz wifi network. It will not work on a 5 GHz network.

@Pershler - you are not being annoying. My Rachio 3 is one of the early versions as it was a gift from my Realtor when I bought my house 3.5 years ago. I just had not installed it yet. It is apparently one manufactured before Rachio came out with the firmware update that apparently fixed this issue. So I am stuck.

@Zachio - I tried to login to my Rachio account using my kiddo’s Android phone, and it would not even let me log in! It kept telling me “no account with that user name or passcode exists” or some words to that effect, even though I logged in fine on my own iPhone (and yes, I double- and triple- and quadruple-checked the username and password that I input). So I am still not able to get the Rachio online. I will have to try my laptop this weekend. Hopefully that works. Luckily, we have had a lot of rain recently, so my plants are not dying yet.

Is there no way to update the existing firmware?

Since the problem is that it won’t connect to the internet, unfortunately there is no way to update the firmware. I have to get it to connect before it will update. I will try the force add recommendation this weekend. My delay is I just don’t have my new laptop set up yet. I will do that this weekend and report back.

Okay, quick update – I tried the BAT file and also the force add via cURL commands and neither worked. After troubleshooting briefly with Rachio support, they have agreed to send me a new controller. Hopefully the replacement will connect easily. Fingers crossed!!