Rachio 3 and Homekit


#1

I waited and I waited for HomeKit compatibility… When it was available I purchased the Rachio 3… Now, I am finding that in my Home app the Rachio is not available with “No Response”… I have cleared this problem twice now and the only way that I can figure out how to do it is to return the controller to factory and set it back up remembering NOT to remove the controller from the app (so as not to lose everything). This method seems to work but only temporarily.

Using the Rachio from the Home app is pretty rudimentary and frankly useless except for manual watering which sort of defeats the point of the smart controller. This still doesn’t change the fact that it’s not working inside HomeKit as it should and as promised…

Is there a fix coming up in a future update?


#2

The only time I’ve had mine report “No Response” in HomeKit is when I had the controller in Standby mode. Hope they’re able to figure out what’s going on with your system.


#3

This topic looks to be a duplicate:
https://community.rachio.com/t/rachio-3-not-responding-in-homekit-again/17689/2


#4

I’m not sure what is exactly the issue, but mine has done the same thing, then self corrected after a few hours. Honestly, I didn’t buy the Gen 3 for HomeKit integration, so I’m seriously considering disconnecting it from HK. The only advantage that HK offers is creating run times less than one minute, which I use when troubleshooting or adjusting individual sprinkler heads.


#5

Yes I posted in Feedback for Rachio as well as troubleshooting to get potential help from the community. Is that a bad thing?


#6

Chris, it’s not necessary a bad thing but since both threads are visible to Rachio and the community, it can create confusion if some folks respond to one thread and other folks respond to the other.


#7

Hey @Macsterguy and @chrisandeden!

Would you both be up for reaching out to support@rachio.com directly so they can dive a little deeper and troubleshoot the integration with you? They might have you do the same thing (factory reset) but I would love for them to have the opportunity to look into this further and log any issues.

:cheers:


#8

I have already gone thru this with support and have since had to reset the controller 2 more times to be able to add it back to Homekit. The next would be the third time. I was told that this would be fixed in a future update (probably a month or so ago). Unfortunately I am way to busy to help support gather logs etc right now. Possibly in a couple weeks…


#9

Totally understand, @Macsterguy! I’m sorry that this is still causing headaches. I’ll check in with the team and see if I can gather any updates!


#13

Hey @Macsterguy - got an update much quicker than I expected. Sounds like we’re waiting on a 3rd party to make some updates that will allow us to finish the updates on our end. Don’t have a timeline, but please know that it is being worked on!


#14

I’m happy to reach out, but I don’t currently have an issue. There are three different times I’ve noticed my controller was showing the ‘No Response’ message in HomeKit. The only reason this is somewhat annoying is that HomeKit says there are ‘17’ devices not responding, because the controller, plus all 16 zones count as individual devices in HomeKit. So as long as all my data is backed up, and can be restored from the cloud, I’m fine with working with support, even if they do need to perform a factory reset.


#15

Good to hear Laura. I’m sure Apple is “as easy as pie” to work thru this stuff with… Hahaha. You will finally get it fixed then they will probably break it in the next iOS update. I don’t envy Rachio at all in this, nor do I blame Rachio in any way. I know you guys are on it and I recommend Rachio to anyone I can. Thanks for the update :slight_smile:


#16

:wink: I’ll keep you updated as I hear more!


#17

I had that problem.

I fixed it by installing a wifi network extender somewhere in between the wifi router and the sprinkler controller.

When the extender is working, I have no problems.


#18

Signal strength is not the problem. Thanks for the tip though


#19

Macsterguy,

I don’t know how technical you are, but could you try disabling 5GHz within your wireless access point or router? IoT devices generally only use 2.4GHz, but are known to have issues when an AP or router broadcasts in both frequencies with the same SSID.

If you can do this, try leaving the 5GHz radio off for a few days, and see if your Rachio remains connected during that time. If this does resolve your issue let me know and I can give you some pointers on a permanent fix.


#20

Try removing the Rachio 3 accessory from home and
Then re-adding it.

If you’re still encountering issues,
Factory reset the controller.


#21

Thank you for your reply Prunt,

I use a Synology AC2600. It is an amazing router and will let you do pretty much anything you want. You can turn 2.4 or 5 GHz bands on/off. You can assign more bandwidth to individual devices… etc etc etc anything you could want…

The Synology router, on it’s own, has connected to the Rachio controller on the 2.4 Ghz band without my intervention… I’m using this router in “smart connect” mode where it does all that for you automatically. I’m having no issues with over 30 smart home devices throughout my house from various manufacturers. This is one of the main reasons I bought the Synology router.

I would prefer to use the Rachio3 as Rachio says it can be used. This is from the Rachio router requirements page:

Rachio controllers support both dual band and single band routers ; a steady 2.4 GHz connection on a secured (WPA/WPA2) network is required for Generation 2 and Generation 1 controllers, but Rachio 3 can use either 2.4 GHz or 5 GHz connection on a secured network.

This is not a BIG deal for me… Since adding the Rachio to Homekit is really limited in ability, (Other then saying “Hey Siri, water my grass” as my wife or grandkids are walking / playing in the yard), I would rather just use the, far more capable, Rachio App for now anyway…

I understand Rachio is working this problem and since they have to work with Apple on this, I can only imagine the difficulty that brings to the table.

I’m going to wait for Rachio to sort out the problems and do it right.

Having said all that, IT SHOULD WORK and your suggestion is definitely one that I had considered and is the issue that Rachio needs to fix in my opinion