Quick Run Stop Button Blocked on Android

Hi. When using Custom Run on a zone, the Stop button gets blocked by some other panel in the app making it impossible to stop the zone. It appears as if the screen containing the Quick Run display sits above another panel and doesn’t completely cover the panel underneath. In fact, the top panel (custom Run) is dropped down just enough as to slide the controls (the stop button, etc.) beneath the Android bottom buttons. It doesn’t happen on Lawn zones, just on plant zones. See attaced…

OK here. Possibly related to your zone picture, or a specific device. Is the issue present on other zones? On another phone or tablet? At app.rach.io?

@steve.palmerin ? :confused:


Never seen this one before. @BigHeadDog Could you try clearing the app data. You can do this by going to settings -> apps (applications on some devices) -> Rachio -> “Storage and cache” and select clear storage. You will have to login again but this should hopefully resolve the issue.


I didn’t have a Clear Storage option on my Samsung S9 but I selected Clear Cache and it appears to have worked as you described.

Thank you,
Thom K.

Ok. That fix doesn’t stay fixed. I cleared the cache and it works for one or two times but then it goes right back to where I can’t see the buttons. This is very, very annoying when I’m trying to run through zones manually for maintenance, and all of a sudden, I randomly can’t stop a zone and I have to go out of the app, clear the cache and go back in the app and reload everything.

This happens because your app makes a ‘card’ for the current zone and pushes it down the screen. In the original posting above, you can see the background ‘card’ for the “Rachio-E0B217”. There is no navigational reason for this: Doesn’t my Back button go to the same page that clicking on that background card goes to?

If this is something because of iPhones, then please move the buttons higher on the card or actually make the Android version different and don’t have the background card for the controller.

Or, change the size of the buttons: Why is pause the biggest button? Who uses pause the most after starting a cycle? It’s not even “pause” is actually “snooze” since it is for a set time.

Or, add stop to the pause button options: When you hit it, the first option is to stop and then you can have the options to snooze for a time period. Since you can still hit the pause button when the interface is broken, this seems like an easy, interim measure.

It’s a very slick app but I would gladly trade (slow) animations for the ability to consistently control my sprinklers.

Thank you!

Also, I just made the mistake of hitting the maximize button on this post and on Windows 10 with Chrome, coincidentally, the buttons to post/cancel etc. are there but immediately get concealed under the banner and resizing doesn’t help. Only hitting ESC brings it back which I don’t see labeled anywhere, but I may just be missing it.