Problem Solved: Connecting Rachio 2nd Generation to ASUS RT-AC66U


#1

FYI. After spending more hours than I’d like to admit trying to connect my Rachio 2nd Generation to my ASUS RT-AC66U router, I finally succeeded - albeit with an out of the box solution.

What didn’t work:

  • Following instructions.
  • Opening port 31314.
  • Changing my 2.4 GHz band to Legacy, or enabling B/G protection.

What I refused to do:

  • Disable my firewall.

What did work:

  • I set up a spoofed WIFI network via the hotspot functionality on my phone to pair the device with Rachio servers.
  • Then I turned it off and reconnected to my ASUS router.
  • Magically, all four lights lit up!

How to do it:

  • Make note of your router’s SSID and password (pre-shared key).
  • Turn your router off.
  • Grab a hotspot or enable the hotspot functionality on your phone.
  • Configure the hotspot with the same SSID and password as your router (that you turned off).
  • Pair a second phone or tablet with your hotspot.
  • Setup the Rachio via the second phone/tablet, entering the SSID/password for your hotspot.
  • Follow the prompts until all 4 lights light up.
  • Disable the hotspot.
  • Turn your ASUS router back on.
  • It should then connect perfectly - all 4 lights.
  • Finish wiring and complete configuration if needed.

_For the record, the firmware of my ASUS RT-AC66U at the time of this post was: 3.0.0.4.378_9533.

I’m guessing that this method would likely work when struggling with any other Apple WAC or Electric Imp BlinkUp device, but I don’t have any others.

Enjoy.


#2

Thanks for sharing. Sorry you had to go through this, I haven’t heard of any issues with ASUS routers, that is usually our power house (I have one at home and we used to run everything on one at work ASUS RT-N66U).

For anyone reading this, these are not normal steps, but using a hotspot is a creative solution.

This is only for Gen 1 :wink:

For only pairing this might help…

Were you using a Gen 1 or Gen 2 device? Gen 1 is blinkup, Gen 2 is the Apple WAC process.

:cheers:


#3

There is definitely an issue - at least with this Asus model/firmware. I spent probably about two hours on with tech support, not to mention the other hours (plural) I spent reading message boards and trying different things. It was horrible. And it was Rachio support that suggested opening the port.

Just goes to show you how determined I was to get this thing running - because I’m excited about it!

It’s 2nd generation, I’ll update the note.

Thanks.


#4

Thanks again for sharing.

Just curious, were you running a dual band or dedicated network that you were pairing to?

Also, I’ll PM you some Rachio swag, no one should have to spend that much time…most connections only take a minute or less.

:cheers:


#5

Dual band, with unique names for both bands.


#6

So one dedicated 2.4g and one dedicated 5g?


#7

Yep.


#8

Ok, very strange. Well glad you are part of the community.

:cheers:


#9

MAC filtering disabled, I even gave it a static IP to keep it from squirming around on me.


#10

Agreed, and thanks, I’m glad I made it to the other side. It should be worth it. I’m already happy with it. I did discover a broken pipe on the maiden voyage though. : (