OnHub Router Connection


#1

Anyone successfully connect a Gen 2 controller to a Google OnHub router? I just installed mine and it’s not connecting to the router. Wifi signal is strong to the area where the controller is installed. But as I am reading, Rachio has trouble connecting to dual band routers that don’t differentiate between 2.4 and 5GHz network bands of which the OnHub falls under.


#2

Do you have different SSID’s for the two bands?


#3

Nope…the OnHub doesn’t support unique SSIDs.


#4

That may be a show-stopper. I am also presuming the router will not allow you to temporarily shut down the 5 GHz band?


#5

@DancherBoi, the Rachio controller requires a 2.4 network by requirement of the WiFi chip. As you noted, OnHub blends the SSID and forces the device to choose a network; I’m sure other users with the same product using similar WiFi chips will experience a similar issue and OnHub and the WiFi chip manufacturers will be forced to find a middle ground. Until then, I’d recommend setting up a stand alone router that supports 2.4 only to run your Rachio controller on.


#6

I spoke with a Support representative who suggested I connect the Rachio to the guest network using the default settings. Unfortunately, that didn’t work either, which means that the guest network also switches bands automagically.


#7

No, it doesn’t. This router is supposed to be a set and forget device in anticipation for the Internet of Things.


#8

That’s a unique suggestion as an interim solution. Thanks for that. I think I may just have some old Linksys router I can use for the time being. I just hope a more elegant solution presents itself soon.


#9

@DancherBoi Ditto! We’ll do some digging to see if we can hack into it :wink:


#10

@DancherBoi, which OnHub router do you have?


#11

I’ll check your firmware version and make sure on latest and greatest.

:cheers:


#12

I’m also going to reach out to our WiFi chip vendor and see if they have had any issues with this router.

:cheers:


#13

I’ve sent a message to our WiFi chip vendor and will let you know as soon as I hear back regarding any known issues or configuration settings with the OnHub router. Thanks for your patience.

:cheers:


#14

ASUS


#15

Are you talking about Rachio firmware or ASUS OnHub? The OnHub updates automatically…I can’t force it to update.


#16

The Rachio firmware, once the device is online we can determine your version.

:cheers:


#17

Thanks for your help trying to figure this out. In the meantime, this is kind of a disappointment. I invested in the OnHub router to simplify my technical life. It’s a great router with awesome speed and range. It’s built for the next generation of IoT led by Google (aka Alphabet) (who of course owns Nest). The OnHub hardware supports their framework including protocols for Brillo/Thread and Weave. Rachio is listed as a partner for the Nest incarnation of Weave as per this blog post on the Nest website…

So I thought I was going to be somewhat future proof…but the reality is that the Rachio flagship latest gen device can’t even connect to the WiFi signal of this router. What does this say about future support for Weave?

So in my quest to simplify, I have to complicate. In other words, I have to create a second 2.4GHz network at my house and keep that running along with my OnHub router. I feel like I am moving backwards.


#18

Well, let’s turn this thread upside down. I just spent 2 hours trying to get my Rachio to connect to a 2.4GHz network, and it never did.

I created a new 2.4GHz only network (Wireless-N) using an ASUS all-in-one pocket router along side my OnHub network. Rachio wouldn’t connect to this network.

I created a new 2.4GHz separate network on an ASUS RT-AC87U along side my OnHub network. Fail.

I took down the OnHub network completely, factory reset my RT-AC87U to all basic settings with disparate 2.4 and 5GHz networks. Fail.

And a bunch of little trial and error in between, each with a WiFi reset and reboot of the Rachio in between each of my tries.

Unless I am just dense and doing something completely wrong…I think my unit is bad.


#19

I’m using a Asus RT-AC68U with complete success. Have you tried turning off the 5 GHz band on the RT-AC87U? This will insure everything, including your mobile device, if this is what you are using to attempt connection, is also talking on the 2.4 GHz band.


#20

I PMed you for more information. Not entirely convinced that it’s your router, could be the mobile device you are using for pairing. With more information we can quickly troubleshoot the issue.

Thanks!