Not seeing Smart Cycle in program preview?


#1

Hi Rachio.

New user here so this may well be “operator error”.

I’ve set-up my new Iro, set-up my zones (soil, slope, nozzle, etc), and added a watering time for Thursday morning (my day under my local watering restrictions). Iro has calculated a program that runs 1hr 26min, but each zones runs just once for the calculated time – I was expecting these runs to be broken up due to Smart Cycle being enabled.

For example, my “front mailbox” zone is:
vegetation: warm season grass
soil: clay
exposure: lots of sun
nozzle: fixed spray head
slope: slight

According to the Smart Cycle Overview I should be seeing a max runtime of 6 minutes.

But instead I’m seeing a runtime of 11 minutes, almost twice that.

What am I doing wrong?

Here are some relevant screenshots:


Smart cycle not kicking in?
#2

@ramblinwreck

From the looks of it, you can’t mix different nozzle types since we didn’t want to cycle/soak things like bubblers, emitters, or misters. We could do a better job of documenting this. The matrix in this article purposely excludes those nozzles, but we should be more explicit.

I would try creating a watering time without those nozzle types and you should see expected results.

Let us know if you have any more questions or feedback, have a great day!


#3

Thanks @franz! That was it. I had inadvertently set one of the nozzle types to emitter. I fixed that and now the program has been split into two cycles, as expected. No problem. Your explanation makes sense. :slight_smile:

Two more questions on this topic:

(1) Total duration is 1:26. Iro is splitting that into two 43 minute cycles as expected (see the screenshot below). Given that the first cycle starts at 4AM (and completes at 4:43AM), why does the second cycle wait all the way until 5:26AM to start (precisely 1hr26mins after first cycle, where 1:26 corresponds to total duration time). I thought it would start straight away since the minimum 30 minute soak time had been satisfied (I read on Rachio support pages that Iro only need to wait 30 minutes for “soak”). I’m seeing a gap much larger than that, over an hour…

What I’m hoping to get is each cycle starting as soon as possible after first one completes (after satisfying 30 minute minimum soak requirement). Reason is that we only have certain hours we can water here (restrictions) and therefore I need as “compact” of a program as possible when using cycle soak to fit into the window of time I can water. For example, was hoping this program would have been complete by 5:26AM, running two 43 minute cycles back-to-back (since 30 minute soak minimums were satisfied). Is this possible?

Perhaps I need to create multiple Watering Times, one for each zone, in order to stack all the run times to achieve this? Or some other way?

(2) Viewing the Watering Schedule in “2x” (or 3x, 4x, etc) view shows two cycles, but viewing in 1x shows just a single cycle. Is this a bug in the app or am I misinterpreting the data?

Relevant screenshots:


(2x view, 2 cycles as expected)


(1x view, 1 cycle, unexpected)



#4

With regard to #1, I just read your article “Best Practice Watering Times” which suggested:

Creating a watering time for each zone will enable our system to create the most accurate cycles based on the available data. […] This is ideal and will allow our algorithm to really specialize watering according to each zone.

… I tried that, but I’m still seeing lots of gaps in the run times that I don’t want.

Using the example I’ve given above, is there any way to program Iro to run the two 43 minute cycles back-to-back?

Thanks!


#5

@ramblinwreck

(1) Can you create a watering time and PM or comment the name here and I will take a look at it on your device? We do account for a 30 minute gap and it should run the other zones if that gap is fulfilled. Just need to take a look at your schedule and I’ll be able to explain it and determine if we have an issue with scheduling.

(2) Correct on the 1x, 2x, etc. display. It’s by design, one of the things we are re-visiting with our 2.0 app rewrite to make it easier to understand.

Thanks!

:beers:


#6

@ramblinwreck If you can send me the watering time name you created I will take a look into what is going on. thanks!


#7

@franz, OK, I did it both ways to illustrate what I’m seeing.

Method #1: (Wednesday @ 4AM) one single Watering Time for multiple zones. This is the method I was using the create the above screenshots.

Watering time name:
Wednesday - multiple zones

NOTE: For some reason the Wednesday total duration is 1:37 (splits into two 48:30 cycles) instead of 1:26 (splits into 43 min cycles) as shown in the example above. Not sure why it’s different. Maybe I changed something inadvertently. But the issue is the same. What was hoping for is two cycles of 48:30, running back-to-back.

Method #2: (Thursday @ 4AM) multiple Watering Times (one Watering Time for each zone). I tried this according to “Best Practice Watering Times” article on your support pages. Still seeing lots of gaps with this method, also.

Watering time names:
Thu - front mailbox
Thu - front main
Thu - front shrubs
Thu - right ac
Thu - back bed
Thu - back swing
Thu - back swale


#8

@ramblinwreck Looking at the underlying schedule on the device it is giving the desired behavior with no soak period since you exceeded the 30 minute soak period, so you have back-to-back runs of cycles.

It does look like there might be a display issue on the calendar rendering, looking into that.


#9

@ramblinwreck The display issue has been fixed and corrected on our servers. Thanks for finding this :blush:

We pushed a large release a few days ago in anticipation for 2.0 mobile/web software including our flex schedules and this looks like it slipped through. PM me your address and T-shirt size if you want a Rachio T-shirt.

:beers:


#10

Hi @franz, I confirm that the calendar rendering is now what I expect for “Method 1” described above.

PM sent!
Thanks!