Issues loading account through Alexa


#1

I can find Rachio under skills in Alexa. I tried to connect (got a pop up saying Alexa was requesting access to my rachio account, which I allowed). It then prompted me for login credentials (which I typed right–I validated by revisiting my account on a regular web browser) and then the screen just says “loading…” for minutes on end, but never connects. Result: no Alexa integration so far. I have a 16 zone gen 1 device. One of the first backers and got the high-end model. So… …why isn’t this working?

P.s.: why can’t I use my Rachio credentials to log in with the Rachio community?–had to create a separate account.


#2

@inglenoir - I’m afraid I’ll have to let someone with more experience with Alexa integration tackle your primary question. (I’ll see who I can recruit for that.)

As for your P.S.

The username and password for the Rachio App and the username and password for our Community Forum are independent logins. When you click on Help from the Rachio App you are brought to an embedded web-view within the app. Since it is its own website, it has a different username and password than that of the App.


#3

@inglenoir, sorry to hear you’re having trouble connecting your Rachio to Alexa. The Gen1 is compatible with Alexa. Are you still having trouble? If I’m understanding correctly, you’re getting stuck after step 4?


#4

Yes, I’m getting stuck at step 4 (per this page: http://support.rachio.com/article/483-how-do-i-use-alexa). It only asked me for my login credentials the first time I tried to access my account (which I entered correctly, leading me to the endless “loading” screen). I’ve tried everything: logging out of my rachio app and even uninstalling it from my phone to avoid any conflicts, disabling the skill, reloading it, etc. However, it no longer asks me for username ans password: it only prompts me to link my account and then dies–as it step 4 were automatically bypassed. As if my access credentials were stored in some cache. In any case, this is really frustrating from a user standpoint as there is no rhyme or reason to why this is not working


#5

@inglenoir, thanks for the update.

That sounds very frustrating, but isn’t necessary as the integration is made between your Alexa and Rachio accounts via the cloud.

What browser are you using? Have you attempted to connect using a different browser?

I would be frustrated too. We haven’t heard of any other Alexa issues, so I’m confident the integration is working properly – we just need to isolate the issue you’re experiencing. I know you’re working with Tom in support. I’ll review your support ticket and follow up with any additional troubleshooting ideas.


#6

Hi there,

Similar issue, but after typing credentials I get a blue Rachio screen which says Synchronizing user data. I’m 90% certain I didn’t fat finger the password but even after closing the Alexa app and rebooting the phone I don’t get opportunity to re-enter the reds. It goes straight to this screen when I select link the account again.

Running IOS 10.0.2

Submitted a support ticket haven’t seen a response yet.

Any help appreciated! Thanks


#7

Hi @mrjamesm!
I see that you were able to connect with support on this issue, and it ended up being because the device was shared with you rather than on your account. Sorry for any inconvenience, and if you would like information on how to switch the controller to your account let me know!
McKynzee :rachio:


#8

Hi - Yes please! I may have created an issue for myself, I deleted the controller for the account interpreting some of what I read online as I could just re-add it, but it tell me that it can’t add it because - I think it said that the device already has that SSID… Can’t quite remember but I’m sure you guys will know the logic :slight_smile:


#9

@mrjamesm Hi James! No problem at all! So if you deleted the controller from your account you also need to factory reset it before you reconnect it to your account. Instructions on how to do that can be found here: http://support.rachio.com/article/471-factory-reset! Then you should be able to reconnect it no problem. If you have any other issues let me know :slight_smile:


#10

Hey - It says that on Gen 1 (which I have) the factory reset can only be done via the - which it’s no longer connected to…


#11

@mrjamesm I’m sorry, forgot to send directions for Gen 1! You will need to power cycle the controller, so just unplug the controller for 15 seconds and then plug it back in. Let me know if that works