Issue manually running a schedule


#1

I have run into a failure today trying to manually run a schedule. There are three zones on the schedule. Also, the system rain sensor is activated (which is why I wanted to run the schedule manually.)

I start the schedule by clicking on “run schedule” in the schedule display. The UI says the schedule is running, but there is no watering happening. also at the end of the time for the first zone, the UI stalls. It does not move on to the next zone nor can I stop it by clicking on “stop”. The only way to clear this is to do some other manual watering.

I have since used the individual zone watering and with this path the watering does actually happen and it stops after the anointed time duration.

If I were to guess, I suspect the rain sensor is mucking things up. So I also request a new feature–the ability to exclude a zone from the rain sensor handling.


#2

Hey @sbillard-
Sorry for the delayed response, I must have missed you post! This is definitely due to your rain sensor. Rain sensors work in your controller as interruptions, so they essentially break the circuit. You can try to run, but electrically your controller will not be able to. Unfortunately, due to how rain sensors currently work, it would be really difficult (maybe impossible?) to have this only affect certain zones through the app.
If you don’t mind me asking, why do you currently use a rain sensor? Does weather intelligence not work well in your area? While I absolutely see the value in rain sensors, I would hope that weather intelligence can work well enough to eliminate the need for rain sensors.
Let me know!
McKynzee :rachio:


#3

There must be a more in depth issue here. The rain sensor DOES NOT stop me from running a schedule with a single zone. Nor does it stop manual running. The issue shows up only on this multi-zone schedule.

Anyway, to answer your question. The rain sensor was there on the old system and just got carried forward. Can I just turn it off in the UI or do I need to disconnect it from the hardware? Weather Intelligence should be ok for me. The weather station is a bit far away. There is a really good station near by, but it is on WeatherLink and not mine. If I could only use that one…


#4

Just IMHO, but because my weather station is a couple miles away from me is precisely why I like having a rain sensor at my house.


#5

@sbillard I am realizing I made a mistake in my original response- and after testing I think I have a better understanding of the issue you are running into. Are you able to run a single zone schedule manually while your rain sensor was enabled? I had issues, curious if it was just me. You can just disable in the UI and it will stop using it, however I don’t want to discourage you from using it if you have it! Like @Linn said, it can be useful when the station is a little ways a way. It’s like a little extra insurance!
McKynzee :rachio:


#6

Yes, a single zone schedule can will run manually without problems.


#7

@sbillard-
So after some testing on our end, we’ve discovered that this is actually a software issue. I let our development team know, and they will prioritize it in our backlog! Thank you for helping us identify this. For now, my best recommendation would be to either use the manual run feature while your sensor is enabled, or disable your rain sensor when you would like to manually run the schedule. You can just disable it in the UI and should be fine, no need to go out to the garage and pull wires out. I know these aren’t great, I am sorry for the inconvenience!
Thanks again Stephen-
McKynzee :rachio:


#8

Thanks. The rain sensor has deactivated now, so at the moment it is not a problem.


#9

Hopefully you won’t run into it too often!