iOS app update - not working

The recent iOS app update has caused the app to no longer open. iOS version 4.6.2 running on iOS 15.5.

I’ve already tried to uninstall and reinstall however same behavior.

No issues at the moment using the web version :wink: so I guess I’ll just have to wait for the iOS app fix to get re-pushed.


Actually, I read your post and noticed mine wasn’t working either. However, after checking, I had not updated the app yet.

New app version installed
Not working here also on iOS
Sadly this is becoming a weekly thing around here. Where is the QOL


Same here… app didn’t work, updated it to the latest version and still won’t load. Saw they just updated the design, maybe why.

Been really frustrating lately, worked fine for years but now constant issues.

1 Like

My work last night now is on welcome screen. Looks like system is down again

I guess it’s a system issue and not related to the recent app update

Wow this system been down more this month that it always had been for the pass 5 years I own it

1 Like

Same problem here. It isn’t “slow” to load it just doesn’t work/load. Major headache

I’m having the same issues