IFTTT recipe not working?


#1

Is anyone using the IFTTT recipe “Track watering in a Google spreadsheet”? I’ve got this enabled, but I’m not seeing a spreadsheet created/appended when I run my zones (I’ve manually ran a few cycles for some adjustments to my nozzles).

I realize this isn’t an IFTTT forum, but hoping some folks here my have experience with this. I’m new to IFTTT (this is my first time using it), so this may well be something I’ve not set up correctly. Any ideas on what to check?

Perhaps it works only for regularly scheduled watering times, not for manual zone activations?


#2

@ramblinwreck This is currently only supported for scheduled schedules.

I’ve put in our backlog to support manual runs, no ETA on delivery.

:beers:


#3

No problem @franz, thanks for confirming.


#4

Hi @franz, I’m not sure it’s working for scheduled runs, either. My regularly scheduled (Thursday morning) watering times ran this morning. This is all I’m left with in the spreadsheet:

http://goo.gl/lkvsDL


#5

@ramblinwreck Interesting, I will run some tests today and see what I come up with.


#6

@ramblinwreck So I ran a 5 minute schedule and am seeing expected results.

Here is my recipe (write a row to Google Spreadsheet every time a schedule stops). I see the 5 minute duration and the date/time and name of the schedule.

Let me know if you have any questions. Thanks!


#7

My recipe is pretty much the same (i.e. I used the defaults that came with the recipe). Only thing different is my path, I just have {{DeviceName}} without the “Rachio” directory name above it. But I doubt that’s the problem. In any case, I’ve just changed it to the way you have it and will report back next Thursday when my WTs run again.

Not sure if the complexity of the schedule matters here? I’ve got 2 WTs covering multiple zones each, with Smart Cycle enabled.

Anyhow, this is low priority. I’ll let you know my results after next Thursday’s run. We are on 1-day a week restrictions here in Central Texas so won’t have another chance until then. :slight_smile:


#8

@ramblinwreck Ok, complexity shouldn’t matter, just care about the watering ‘stop’ trigger.

Just ran it again and it appended a new row :smile:

How crazy is it that your irrigation controller can write to a spreadsheet in Google Drive? :+1:


#9

OK, I just realized my recipe is different. The Formatted Row for me is:

{{WateringTimeName}} ||| {{CreatedAt}} ||| {{DurationInMinutes}} |||

What I got is this (this is snapshot from the spreadsheet I linked above):

This still seems wrong because:

(1) None of my Watering Times are named “Every Thursday at 1:00AM” (as shown in above spreadsheet I linked). That texts happens to be what I see below the Watering Time Name on my watering Times page. It’s like it’s pulling from the wrong field. See here:

A thought… On the Watering Time setup page for each of my WTs, I left the NAME field blank. The Iro seems to assign (or at least display) a default name “Water [zones…]” (as shown above). Is this the problem? That is, perhaps I need to assign an explicit name for my WTs in order for this recipe to work, rather than relying on the default name that Iro is showing? Maybe this causes the recipe to grab the wrong field/string since the NAME field is blank? I had assumed it would use the one Iro is showing me, but maybe a bad assumption.

(2) I have two WTs (shown above) that ran this morning, yet only one entry in the spreadsheet. I was expecting two entries in the spreadsheet, based on the “this trigger fires every time a watering time stops…” description for the recipe. The 40 minutes figure in my spreadsheet corresponds to my 2nd watering time. This suggests that either no entry was created for the first one, or one was created for the first one, but was then overwritten by the second one. Maybe this is because it thinks the name for both of them is “Every Thursday at 1:00AM”?

I’ll add an explicit name for both my watering times. I’ve got a feeling this will fix the problem. Will confirm next Thursday. :slight_smile:


#10

@ramblinwreck I created two schedules with the same name, Test Schedule, and had them run at the same time.

Still seems to be working (rows 4 + 5 I had start at 5:26pm) :slight_smile:

I chose the ‘Add row to spreadsheet’ action from Google. Don’t know if you had chosen that or it matters.


#11

For the life of me I can’t seem to get this working… I’ve tried several times with no luck… I must have brain freeze. Follow everything to the T.


#12

@Lucille, I’ve seen the order get in the way before. How are you setting up your IF and THEN commands?


#13

Also note that some triggers (not ours) there is a 15 minute delay. Ours are real-time.