I cannot connect to my controller using Android Galaxy S20

I just purchased a Rachio 3 yesterday, set it up, and it will not connect to my WiFi. I found the RouteThis information online at received a key code UDTGYH4R.
I do not understand why this will simply not connect. I have all of my devices connected and have never had a problem. Please help! Thanks so much

If you have only iOS 13.4.x, see


for workarounds.

Otherwise, please provide details: Could you get the 2nd quadrant blinking? From what devices did you try to configure the controller? What error messages (or other signs of trouble) did you encounter? Router make/model? Separate access point(s), if any? Any other observations that may be relevant?

Thanks @Stewart. Looks like it could be mesh network issues. @senorsmith Can you try creating a dedicated network?

@Stewart @franz Thanks for the quick reply. I have no idea how to create a dedicated network :frowning: . I use a Samsung Galaxy S20…could that be a problem also?

Yes that’s it. We are getting reports of some S20 phones not connecting. We are working with our WiFi vendor and they are trying to determine the root cause. Do you happen to have any other Android or iPhone devices?

:cheers:

It worked on an iPhone! Now that it is connected via the iPhone, do you know if I can operate it on the Samsung S20? Will there be an update so that it eventually works with the s20? Thanks so much for your help!

Thank you for your patience. The S20 will work fine for control, it is just the initial controller pairing.

Sorry again, the team is working on determining root cause and a potential fix.

Have a great weekend and welcome to the community.

:cheers:

Thank you so much! I already love the system! Stay safe!

Thank you for the kind words, you too!

Please don’t hesitate to ask any followup questions.

:cheers:

Hello Franz. I just had problems getting my Galaxy S10 to connect. Installed the app on my Lenovo Tab 4 and it worked fine. Very frustrating that a mainstream Android phone (and not even the latest model) would not work If its the controller connecting to the Rachio cloud why should the phone even matter?

Confirm that your S10 can access other internet sites.

Confirm that you can still access your Rachio from the Lenovo, or from your desktop or laptop.

When you try to open https://app.rach.io in Chrome on the S10, what happens? Be as specific as possible. Can you get logged in? What error messages are displayed? If you can log in, what doesn’t work e.g. can’t start a Quick Run? If connected via Wi-Fi, try again on mobile data, or vice-versa.

@Kev

We have not had any other reports of S10 not connecting, just the S20. I’ll forward this information to the engineering team for review. Thanks for sharing.

:cheers:

Any update on this issue? Still not working on my S20. System is accessible from my wife’s Pixel 2.

The previously reported S20 issue only affected onboarding. Once your controller was set up with your wife’s phone, you should be able to operate it from the S20. If not, yours is a new problem. What goes wrong when you try to use the app?

Even if the app is broken, for adjusting heads and the like, you can access app.rach.io from your S20.

If you’re doing anything complex such as planning schedules, just use your desktop or laptop; it’s much easier with a big screen and physical keyboard.

1 Like

We have have the Rachio 3 for over a year. It worked fine until I got the S20 Ultra. If I reinstall the app, it logs right in and functions normally. Then after an hour or so it says the unit is not connected to the internet. However, I can still access on the computer or my wife’s Pixel 2.

Very strange. You are likely this first to report this. When the app shows not connected, can you access app.rach.io from the phone? If not, can you access other sites on the internet?

@steve.palmerin Thoughts on this? :smile:

:cheers:

I can’t think of any reasons why the Galaxy S20 would be showing the controller offline and the Pixel 2 showing online. At this point, the app is only communicating with the server and even if the request to get the current state fails, we would not show the controller offline. If this issue continues to persist, could you send us a timestamp on when the phone starts showing offline? We might be able to identify what happened in the logs.

1 Like

I’ll double check when I get home with one of my test R3’s, but this weekend I was tinkering with one at I had no issues from my S20 Ultra.

1 Like

Hi, I created a community account just to confirm that my Samsung S10 does NOT work to do the on boarding process. My wife and I wasted an hour trying to get it to work with a combination of home wifi and mobile hotspots. I dug out our old Samsung S7, installed the Rachio app and it immediately worked. Not a good first impression…