How I fixed my Not Responding issue with HomeKit


I tried connecting Rachio to HomeKit a few months ago & had issues right away just pairing. When I finally did get it to pair, I got the dreaded “Not Responding” shortly thereafter, and it sat in that state since.

I recently changed my WiFi SSID, and had to reconnect to my devises. I had a real hard time with one of them, that had initially paired easily, and had been working just fine for a year, but just WOULDN’T pair after changing my SSID.

While troubleshooting this, I noticed in the Home app settings, a row I believe was labeled Network & WiFi (below Speakers & TV). When I clicked on it, it showed my routers (Upstairs & Downstairs Eero Pro 6), and it said they were not responding, despite all Home devices connected & functioning (except Rachio).

This obviously made no sense as I wouldn’t have a WiFi connection without the routers. I rebooted the routers anyway, and noticed they briefly showed as connected in that Home settings section, then right away they showed as not responding again.

I decided to delete the routers. When I went to delete the 1st one, a message came up saying something to the effect of I’d lose security if I deleted the router; I deleted it anyway.

After deleting the one router, that row (Network & WiFi?) disappeared from the Home settings, and hasn’t come back.

Right away I was able to connect to the device giving me trouble (that I couldn’t pair for hours), so I decided to try connecting the Rachio. I removed Rachio from my Home, and was able to pair it right away; it has been up & running since…

If you’re having issues with Rachio & the Home app, I would suggest looking at the settings to see if a Network/WiFi row exists (below Speakers & TV), and delete your router if it’s there.

All that said, as part of the troubleshooting process, I deleted My Home from the Home app, then deleted the Home App from my phone, rebooted the phone, re-installed the Home App, then re-created my Home. That may have also played a role in restoring full HomeKit functionality/reliability.

I think there were significant updates to the Home app since iOS 15. Everything seems to be working better for me after deleting My Home & re-installing the Home app, so perhaps a fresh start since iOS 15 isn’t a bad idea anyway…

Hope this helps!


Glad you got it working, but there’s absolutely no way I’m deleting my home and all million devices/scenes/automations that I’ve accumulated over the years. If you ever find the not responding thing again, the Rachio plugin for Homebridge (I run it on a Raspberry Pi) works flawlessly.

1 Like