Homekit not working - so dissapointed

Hi,

Bought rachio3 with so much hope as per advertises premium / highly intelligent / homekit compatible watering system controller and I am so so so dissapointed.

In the first two months it got to status not responding in homekit (main reason I bought thos controller!!) quite a few times. Managed to readd it by resetting wifi, but now it won’t do it anymore.
I tried to power it of and on again, rebooted my phone dozens of times, reset wifi, short pressed, longed pressed wifi, re-addes to wifi, but cannot manage to add to homekit. after I add the homekit code, it indefinately scans for controller but nothing is shown. It is like the controller somehow is not pairing/exposing itself to homekit.

I read couple of answers on this thread, but if I am forced to reset the controller to factory defaults that is lame!!! Why should
I redo all my pictures for zones, redo all soil types for each zone, redo all my settings and schedules for a stupid piece of software?! even a smart plug for 10$ knows how to deal with removing and readding to homekit, while a 250$ controller wouldn’t be able to deal with homekit and force me every 2-3 weeks to reset it to factory defaults?!?!?!

I really hope this has a solution w/o reseting the device and redo all my settings!

Ps: my firmware is up2date, but Rachio should really fix their software issues for a so called premium controller! I see lots of posts for people complaining about homekit and lots of promises to fix it but that is for more than a year! how hard can it be to do some debugging and patch the damn firmware?!

There’s a huge thread in the Troubleshooting section, with solutions

Yes, and the last resort is to reset the rachio3 controller… which seems I am at that point, hence my dissapointment!

So you’ve setup a dedicated 2.4ghz SSID ? And you should ensure the channel is either 1, 6 or 11 only - the non-colocating channels

Have a network available, whether it be your primary network or an additional separate network, and whether it be 2.4GHz, 5Ghz, or an automatically determined combination of the two bands, but that has 802.11bgn enabled and is limited to channels 1-11. Also try setting password security set to WPA2 at minimum (should work), and WPA2/WPA3 at most (might not work).

Rachio3 supports 2.4GHz, 5GHz, and dual band networks, but likely needs 802.11n at minimum, and won’t connect to the network if the router uses channels outside of 1-11. Newer routers might have 802.11ac or 802.11ax with 802.11bgn turned off. That would cause a problem, but again, doesn’t sound like yours.

It sounds like you Rachio is connecting to your network, and you’ve gotten the Homekit hub to see it, but it’s possible the Rachio loses connection temporarily if your router is switching to channels outside the 1-11 range.

Since your HomeKit hub has seen the Rachio at least at some point, it doesn’t sound like the issue is isolation between networks either, but if you have separate 2.4GHz and 5Ghz networks set up, your Homekit hub needs to be on the same network as the Rachio. Usually dual band routers, with automatic switching between 2.4 and 5 GHz, will allow devices to “see” each other across the bands, but if they are separate networks, unless the router has a setting to allow this cross band communication, they devices won’t “see” other.

"…Rachio controllers support both dual-band and single-band routers; a steady 2.4 GHz connection on a secured (WPA/WPA2) network is required for Generation 2 and Generation 1 controllers (This is preferable to be separated from the 5 Hz ), but Rachio 3 can use either 2.4 GHz or 5 GHz connection on a secured network.

The Rachio only supports channels 1-11. In Europe, 2 additional channels (12 and 13 are available). If your router moves to one of those channels the network will likely become invisible to the Rachio and drop offline or be unable to connect."

Is my router supported?.

Change Router Settings
To change your router settings , please reference SetupRouter.com (routers are listed alphabetically).