HomeKit & Gen 3, not pairing


#1

I’ve reset WiFi on controller, I’ve rebooted my iPhone, I’ve re-installed the Rachio iOS app…

While standing in front of my controller, on the same WiFi, I put the code in & all I get is this after waiting 30min & starting all over, many times:

Help?


#2

What FW and App Version are you on? Also what version of iOS?


#3

FW:

iOS 12.1

App v. 3.8.3


#4

Okay I think I see what’s happening. Try the following steps.

  1. From Add Accessory click on “Don’t Have a Code or Can’t Scan?
  2. You should see the device below “Nearby Accessories” it will look like the screenshot below.

If you are not seeing this device, it means your either on the wrong network or it hasn’t had enough time to start the HK service on the device. I’ve noticed that on certain routers, even being on different bands seems to cause some issues. I’ve also noticed that it can take a couple of minutes before the Accessory shows up.


#5

The device never shows up like it does in your screen.

For me it looks like this for over 30min:

Then I try tapping on “manual code”, type in the code & then it sits on this screen for infinity:

Been on this for 4hrs now.


#6

Turn Bluetooth on


#7

Bluetooth on my iPhone is always on. Did you mean turn it off?

I let it sit all night on that screen hoping I would wake up to it paired, nothing.


#8

I want to try one more thing. Can you go ahead and factory reset your controller by holding down the stop button? After you have completed the factory reset, you’ll need to add the device back to your wifi network (similar to wifi reset) and then see if it shows up under accessories.

This will not remove your device from the cloud or change any of your cloud settings.


#9

I’m willing to try this as soon as I return home from work today, but will I lose all of my zone head settings? Or will I have to reconfigure my Smartthings/Rachio intergration settings? I’ll do it either way, just wanted to know before I reset. Thx


#10

Those settings are all maintained in the cloud.


#11

Thank you!

  1. I needed to reset (once it fails during syncing, you must reset for it to be seen again)
  2. I needed to move into the garage during syncing (standing in front of controller outside of garage was too far for initial syncing).

Boom! I’m in :+1:t4:


#12

Glad to hear it’s working!


#13

This was EXACTLY the information I was looking for! You should make this troubleshooting tip a front page. I could not get my Rachio to show uo on HomeKit. Was about to do a hard factory reset, but then I saw your tip. Worked perfectly!


#14

I have tried EVERYTHING and nothing has helped me to add the Rachio 3 Controller to the HomeKit / App. All apps and iOS is “Up To Date”…

Everything worked great until recently. I’m not sure exactly when it stoped working. Maybe a iOS update? or App Update?..

I have tried:
• Re-adding the controller to my wifi network
• Resetting the controller then adding to HomeKit with code a # of times
• I have confirmed all devices are on the same network

Any suggestions?


#15

Hmm, seeing this post, I just checked my Rachio in the Home app on iOS. It shows the Rachio as not responding. This was definitely working. Like the OP, I am also not sure when it stopped working.


#16

All I can think of is rebooting your HomeKit hub (iPad or AppleTV) and then power cycle the Rachio. If you tap on the House icon at the upper left corner of the main Home app screen, you’ll get a screen with the hubs listed. If there are none then you’ll need to assign an iPad or ATV as a hub. Just throwing this out there as a stab in the dark.


#17

Thanks for your reply. I have tried exactly what you have suggested with no change. It looks like Rachio needs to work on this. Rachio 3 and HomeKit are essentially broken for me.


#18

I’m very jealous of your setup. I can’t convince my S/O that we need a HomePod lol. Sorry to hear that nothing seems to be budging – I think this effectively isolates the problem to the Rachio controller. HomePod only does wifi so can’t suggest connecting the active hub to ethernet. I also don’t know how to force the ATV to be the active hub without shutting down the HomePod, but could try that and connect the ATV to ethernet. But how annoying (and maybe not possible) to do that!

Have you connected your phone or iPad to the same network as the Rachio, opened the app, go into Controller settings and check if there’s a firmware update available? I forget where the update notification happens, either in Controller Settings or on the Technical Information sub-page. This is my last suggestion as it is likely you’ve got the latest controller firmware. I cannot imagine it being a network issue with all devices on the main LAN (e.g., nothing isolated on a guest network).


#19

My ATV has always been connected via Ethernet and works well. I agree, I don’t think there is anyway to choose which Home Hub is connected… As soon as you setup a HomePod it just becomes the “Boss” of your “Home” and is the Hub by default (short of unplugging it). Rachio has their work cut out for them working in the Apple eco-system. Agreed, This seems to be a Rachio 3 issue…

On the bright side, the capability of the Rachio 3 in the Apple Home App is very, very limited. For now, it is a much better experience to just use the Rachio App…

On the DOWN-SIDE, My Rachio 3 watered ALL NIGHT last night and today we are having a DOWN POUR in D/FW that was forecast for a week… I’m not trying to hyjack this subject and change it to another subject but have a look:


#20

Looks like you’ve got a lot of zones on one schedule — all of which shown above seemed to run for reasonable looking times (near 12-19 minutes each). Total run time may include soaks if you’re using cycle and soak. Another place for data to see what’s going on for historical, current & expected precipitation and irrigation is the soil moisture graph and especially the chart: