History, actual watering time and moisture levels not matching


#1

Something doesn’t seem quite right to me. Gen 1 Rachio.

Here’s the scenario. This morning I discovered that my flower zone hadn’t been watering because things were bone dry, even though Rachio thought it was watering (that’s not the problem – that is probably a valve problem, but it precipitated the next problem).

Unbeknownst to me, my Zone 10 was watering. I didn’t notice this, and I did a quick run on Zone 11 (probably around 12:24pm). The heads did not pop up. So I tried a quick run on zone 1, and it worked. Quick run zone 2, it worked. Quick run back on zone 11 and now it works. Let the zone 11 have two 3 minutes waterings.

Go back and look at History, and my zone 10 had been stopped, and the zone 11 quick run doesn’t register at all.

Question 1: If I do a quick run while the system is already running, shouldn’t it tell me something to that effect?

Now here’s where I start getting really confused. Zone 10 is supposed to run for 63 minutes. It was stopped at 12:25pm after running for 33 minutes.

At 12:49, the schedule started back up again, but it only wanted to run Zone 10 for 6 minutes. Not knowing what was going on, I stopped it from watering. But again, looking at the history, it thinks it went for 56 minutes. (again, making no sense as the total should have been 63 minutes).

When I look at the watering history for the zone itself, it thinks it watered a much longer time!!!

Capture3

And the moisture level chart thinks it’s getting LOTS of water!!!

Because we went from last month thinking we were going to need an ark, to the depths of Hades this month, I did an additional quick run of 30 minutes on the zone so that my plants don’t die, especially since it didn’t water yesterday (That again was my fault – I was cleaning the deck getting ready to refinish it, and somehow managed to pop the ground fault that also controls the Rachio, so it was offline for awhile, again unbeknownst to me. - But in this case a big kudos to Rachio - I discovered a small leak in the drip line while cleaning that I wanted to fix, and when I tried to find it again, I discovered the Rachio was offline, which made me realize the ground fault had probably popped. And since that ground fault also controls my beer refrigerator, THAT was a big deal!!!)

To temporarily fix things, after it gets done watering, I’m going to set the zone to empty to make sure it will water tomorrow.

So, is something wonky? Or have I just gone wonky??? (It could be this crazy heat, high dew point and humidity has gotten to me at last!!!) :stuck_out_tongue_winking_eye:


#2

Engineering team is trying to reproduce on Gen1.

This is actually how it is supposed to work since you never stopped the first running schedule but added manual zone runs. It picked back-up when the zone runs were finished.

Fairly certain this is a Gen 1 firmware issue. Team is reviewing and will push a fix after identifying root cause.

We can’t have the beer refrigerator offline!

There is some wonkiness we are looking into, so not all you.

Thank you for reporting!

:cheers:


#3

Good Morning @Linn,

Thank you so much for reporting that to us. We have released a new firmware that should resolve the issues that you saw. We will continue to watch for anything weird going on but please feel free to reach out to us again if you see wonky things!

Cheers,
David


#4

Thanks @dchau! Hopefully, I won’t run into this again as I’m getting ready to install my Rachio 3!!!


#5

@dchau and @franz, I hate to say this, but the fix has created a whole bunch more wonkiness!!! Several things happening.

On 6/19, I deleted my previous LN Front Flowers schedule. It only contains Zone 11. In past years, I had decreased the watering duration on that zone and I wanted to get rid of the decrease. I set up a new zone of the same name and everything for that zone and schedule seemed to be OK when it ran on 6/20. In the history I see the schedule and the zone 11 starting and completing at 8:00am for 9 minutes. And the moisture level chart for the zone looks correct. On 6/21, the zone was not going to water because it thought I was going to get some rain in the afternoon. It was one of the 20% chances, it’s hot as heck, so I did a manual water for 8 minutes on the zone (good decision as we didn’t get the rain). Again, the moisture chart looks ok for 6/21. Now today thinks have gone all wonky again. I got a notification this morning that the zone had watered for 5 minutes, not 9.

I thought it was just cosmetic as it shows it completing at 8:09am. But the history doesn’t show the schedule or the zone starting. And why is it half reverting back to the deleted schedule?

And here’s what the watering times for the zone show.

And the moisture level chart thinks it also only watered 5 minutes.

But I think it really did water for the full 9 minutes.

OK, on to the next schedule, LN Flex Drip –

Zone 9 shows on the history that it watered on Wednesday 6/20

But the moisture chart doesn’t think it watered at all:

The blue circle is because the unit did a power cycle in the middle of the schedule, and I can’t tell how much it actually ended up watering that zone on Thursday 6/21.

So now, more wonkiness today. Not only did the 8am LN Front FLowers schedule not say that it was starting (on History or by notification), but the LN Flex Drip schedule or zones doesn’t show as anything starting at all, even though it is actually watering. And it’s not just history missing it, but when I bring up the app, either on my iPhone or on the web, nothing shows that the system is currently watering (yes, refreshed app, closed out, restarted, etc.)

And I’ve been getting a rash of Power Cycles like crazy!!! I didn’t realize how many I am getting until I went back and searched the history – I don’t get a notification for them, so I didn’t notice them in all the noise in the history – I’m sure you had a good reason for putting everything into one big history log, but I have to say that I really miss the old way of splitting the scheduled things out separately. It was much easier to pick out rain sensor changes, power cycles, etc when they were in a separate log.

There. Have I confused you enough? I’m certainly confused!


#6

Hi @Linn,

Thanks for letting us know about this. I’ll dig into it and try to get to the bottom of it.

Cheers,
David