GUI glitch prevents downloading CSV


#1

When I log in to the website and try to download the CSV of my water history, there is a glitch in how that screen is generated that slides the link to download the CSV into the X-axis label area. And the link becomes unselectable. I’ve tried this in Safari and Chrome on Mac OS X and get the same result.

I’ve only had my Rachio for 2 days, so I don’t have much data to look at right now. But I thought I’d report the glitch in case you were not aware.

I grabbed a screen shot of the problem, but don’t see an option to attach that here. I can email it to someone if interested.


#2

I went ahead and reported this to tech support and sent a screen shot, too.


#3

@mkresic Thanks for reporting this, our web guru @Dan is aware of this and will work on a fix.

:cheers:


#4

Wow, thanks for making a fix so fast! I checked again tonight and noticed that the download CSV option now shows on the right side and the problem has disappeared, Much appreciated!

One nitpicky feature request that I wanted to throw out there. The downloaded file came down as “Untitled” with no CSV file extension. This was easy enough to rename. But I was wondering what you thought about automatically naming the file something like Rachio-mmddyyyy.CSV.

Just a suggestion. Again, thanks for the quick fix on the GUI issue.


#5

@mkresic,
Just a heads up that it’s likely a network timing issue that was causing your initial problem. No code has been changed around that functionality since you created the thread. That being said, I’m glad it’s working for you and the issue is still on our radar.

Thanks!
Dan :rachio: