Google Home Integration is not working


#1

Hi,
Just got Rachio Gen 2 installed. General control via Rachio app is OK except it is show water usage 573 liters after about 5 minutes of checking 4 zones.

Now Problems:

  1. I was able to integrate Rachio with Google assistant, but after voice command “Water Front Yard zone for 2 minutes” it keep asking for how long and back to Google Assistant. Not able to control at all.

  2. Not Able to integrate with Google Home at all. There is no Any references to Rachio in my Google Home Application.

Any help is appriciated.
P.S. Yes, I did search on support and help and following instructions.
IPhone 5S IOS10.3.3(14G60)
Google Home ver 3.7


#2

Fix your usage:
Precip Rate Calculator.

Determine Zone size with Google Maps. Use satellite view, right click, select ‘Measure Distance’, draw your area and Google will tell you the sq footage.


#3

I’m having the same problem.
There is no Rachio option listed in the Google Home app, and therefore I can’t connect the two.
In ‘More Settings’ there is no ‘Assistant Apps’ listed.
Using latest Google Home v1.24.37.7 on a Samsung S7 edge.
The instructions on the Rachio Support page are either wrong or there is a problem in the software.


#4

Hey @Jammit and @vovkus-

Are either/both of you international users? I do not believe the Rachio integration is available internationally for GA.

McKynzee


#5

I am located in California.


#6

Yes, there are no links to Rachio in the devices list at Google Home app.
Actually Google Home started recognize command “Talk to Rachio” after I reset Google Home but still no listed Rachio devices and this is only one command, which it does. After “Talk to Rachio” I was not able to execute any voice commands.


#7

Hi McKynzee
I am based in Australia - maybe this is the issue?

Do you know why Google or Rachio is imposing this restriction and when it will be lifted? I can’t imagine Google could care, as the Google Home is officially available in Australia.

Until it is resolved, it may help others to update the instructions on your website and tell international customers not to bother trying connecting rachio to google home.


#8

I am having the same issue. Google home tells me to link my rachio in my Google home app, but there is no “rachio” listed in the Google home app.

I am located in the US.


#9

I can connect to Rachio with Google home, but no matter what zone I tell it to water it wants to water zone 6.


#10

Got it to work by renaming all the zone. For me, it did not like the word zone in the name. Also had trouble with similar names ( north 1, north 2). Confirmed that the information was sent correctly from Google Assistant. Rachio did not follow the instructions.


#11

Hey @Bschatzow-

Thanks for sharing your solution. How different are your new zone names, if you don’t mind me asking?

McKynzee :rachio:


#12

A lot different. None sound close. My zones are: Side Yard, Street, Front, Hydrangeas, Maple Tree, North, Butterfly, Back. When I tried North 1 North 2 it did not work. Also using my Pixel phone does not work. Google reaches Rachio, Rachio response, but it never works correctly. Seems to be a handshake issue between the two apps. Google is sending the correct info (it shows on my screen) Rachio responds incorrectly.


#13

Can you give me more details on this?


#14

I needed to use commands that are syntactically correct. For instance,

“Ask Rachio to water zone 3”. Won’t work
“Ask Rachio water zone 3”. Will work

Google doesn’t like the word “to”. (I think)

So, it would be wonderful to have a web page built that has all the successful (fully tested) and typical commands people would use to start or turn off sprinklers. But I believe you have to start with “Ask Rachio…” or “Tell Rachio…”


#15

Also, I had to integrate Rachio over my android phone instead of my iPad because IOS doesn’t list the device but Android did. That is how I got it to link.

BUT WE NEED A LIST ON HELP OF TESTED COMMANDS (in full) that have been tested by the support staff.