Generation 1 loses Wi-Fi connection exactly 2 years (warranty expiration)

I have been trying to reconnect my 2 year old Rachio Gen 1 since May 13th when it went offline after losing power to the controller for an extended period of time with no success. I have followed all of the instructions to the “T” and the unit will show a green middle status light on Wi-Fi for all of 1-2 seconds then start flashing red again (1 long red flash, followed by 2 short flashes). What is the going on? I have not changed routers or settings on it. The router is in the next room to the garage where the controller is at(approx 20-25 ft. away.
Some assistance in solving this problem would be appreciated. If I have to spend more money on a new controller after exactly 2 years of use I will guarantee you it will not be on a Rachio.

@franz might be able to help with this one…

Any assistance would be appreciated.

Assuming you have tried a WiFi reset?

I know that the Gen 1 has typically had better luck pairing with an iOS device than Android.

I just re-paired one the other day and it worked well the first time.

Last resort maybe remove the controller from your account, power cycle, and re-add?


I am using an iPhone 7Plus to BLINK the system with the brightness turned all the way up. I did a hard reset on the the router, and made sure there was no light in the garage while I was blinking the controller with my phone flush to the sensor. It finally captured it after 2 attempts. Thanks for your help. Happy to get the system back on line before we get any more triple digit days here in Texas.

Ok, great to hear you are back online.