Gen 3 Losing Wifi connection

Have had a 12 zone Gen 3 installed for a few months now and all had been working great up till about a couple weeks ago when I got a notification that my Rachio was offline. I noticed that the third section of light bar was flashing red and then white several times. Used the built in trouble shooter and my unit would not connect to my network through the trouble shooter. It would get to the joining network stage and then give an error and attempt to restart the process and in doing so the app would hang up on trying to find device. Force closed the app and started over. Tried numerous times with same result. Finally I pulled the power, waited 10 seconds, and plugged back in. Came right back online… Stayed online for the day and later that night went right back offline. Did same process again and same thing happened following day. Has happened just about everyday since. Ran Route This and got code D9J7TQM9. I’m using a single Asus AC5300 router setup in Triband Smart Connect with 2- 5Ghz and 1- 2.4Ghz bands. Not sure what has changed on Rachio to be causing this all of a sudden. Anyone else seeing this?

Can you create a dedicated guest network on one band to see if that is the issue? Also, is your router firmware up-to-date?


Hi Franz, I have already created a new guest network to see if it helps… So far still online. We’ll see how long it stays that way. As a matter of fact, after submitting my issue even after power cycling which would allow it to reconnect, it would no longer connect. That prompted me to try a dedicated 2.4 guest network. As far as firmware, yes, it is latest update. Not sure why I would have to do this with the Gen 3 as is supposedly got upgraded WiFi with dual band bringing in 5Ghz. I would understand with some older legacy devices.