Gen 3 Controller Drops WiFi daily

Has anyone had the issue where their gen 3 drops from the WiFi connection on a daily basis? My controller is installed near my networking gear and is about 5 feet from the access point it is connecting to. This has been going on for a few weeks now and is extremely annoying.

Someone else has to be having this problem. This is still occurring almost daily, and it is extremely frustrating. I’m running Ubiquiti gear for all of my WiFi AP’s, switches, and firewall if that helps any.

My Gen1’s and Gen3’s have all been rock solid with wifi.

What does your network look like? There are a few network gurus in here that might be able to help.


Not sure what you mean by what does it look like. It was using a single SSID with 2.4 and 5 GHz, but I just added another SSID strictly for the Rachio to connect on and locked it down to only 2.4 to see if that helps.

Well, what type of equipment (routers, AP’s, etc.). @jseymour is a wizard when it comes to decoding network issues, so he might be able to help out.

Not saying that there isn’t a chance that there is an issue with the Rachio unit, but in many cases, network issues play the more common role.

I mentioned all my networking gear is Ubiquiti…complete stack. @jseymour if you have any pointers and are familiar with the Ubiquiti stack let me know! TIA

What kind of WiFi network. E.g.: Make and model of APs? Single or multiple APs? Traditional APs or mesh? If mesh: Everything backhauled with Ethernet? Repeaters? Dual-band? Shared SSIDs? Band-steering enabled?

It may. Let us know.

Just two Ubiquiti Unifi AP’s U6-LR (long range) mesh setup, yes everything backhauled with ethernet, no repeaters. Main SSID that the Rachio was using before today is dual-band with band steering enabled. Early this morning I swapped it over to it’s own SSID with just single 2.4 band.

LOL right after I sent that reply I went to check my Rachio 3 and bam it’s offline. Always blinks the second light waiting for WiFi to be reestablished by using the iOS app.

This is a guess born of nothing more than an impression I get from the complaints I’ve seen here, but, I suspect the Rachio 3 does not deal well with WiFi networks having the same SSID on both 2.4GHz and 5GHz and using band steering.


After mesh networks, my impression is the next largest number of complaints I’ve seen here have been from Ubiquiti users. ICBW.

One thing some have found to be of help when using Ubiquiti APs is setting a DTIM down to 1.

Here’s a discussion of DTIM: What is the wireless DTIM? And how do we use it?

The other thing you might try, if the Ubiquiti firmware allows it, is to set that R3-only 2.4GHz SSID up on only the AP closest to the R3.

To be clear: I’m not blaming mesh networks or Ubiquiti APs for the problems with Rachio 3 connectivity (or Apple HomeKit connectivity). Not in all cases, anyway. In some I believe the makers’ misguided, IMO, attempts to improve their products’ WiFi efficiency are to blame. But I’ve seen enough here to suggest to me there are some issues with the Rachio 3’s network stack.

So in some of my answers I’m trying to come up with work-arounds to mitigate whatever’s going on.

1 Like

Another setting to consider: turn off “fast roaming” and “BSS transition” for the IoT network. In the version 7 UniFi GUI, choose manual configuration and then uncheck those options and save.

At a lower level of the rabbit hole, consider overriding automatic power levels on WiFi radios and choose them manually per band to get a balanced, even distribution of signal throughout the usage space with some but not much overlap. You’ll need a signal strength device for that.

Ubiquiti networks can be really first class but the more APs/WLANs/VLANs you add, the more tweaking becomes necessary. I have a fairly complex setup at home and have had no trouble for the most part.

1 Like

One definitely wants to disable those enhancements for IoT WiFi networks. Those are designed to facilitate seamless roaming. Most IoT devices do not roam.

Fast roaming, in particular, can be problematical for many WiFi clients. See: WiFi Fast Roaming, Simplified

Bottom line:

(Unless you’re operating a RADIUS server, you’re using WPA2/WPA3 PSK.)

Band-steering can, likewise, be problematical. See: 4 WiFi Band Steering Myths

The bottom-line on this one is, IMO, band-steering should never be enabled for IoT WiFi networks and 2.4GHz and 5GHz bands must always have different SSIDs

I’ve fallen out-of-love with Ubiquiti for everything but their EdgeRouter line.

1 Like

I manually set the DTIM to 1 instead of auto, but I’ve technically had the R3 locked down to only communicate with one AP which is only 5 feet away and not roam between the two.

The only way you can literally prevent roaming is if an SSID exists on only one AP.

Theoretically you can prevent roaming by putting a client’s MAC address in other APs’ deny lists. I tried that. It caused my R3 to go off-line. I surmise my R3 tried to associate with the AP in which its MAC address was black-listed, couldn’t connect, and, rather than try the other AP, gave up.

That’s the last thing with which I meant to experiment, but I’ve been otherwise occupied.

Yesterday I upgraded the AP in the home from an EnGenius EAP1300 to a newer EWS377APv3. (Mainly in hopes of realizing some performance improvements [results: Not much] and because the EAP1300 is EOL’d.)

Naturally, in the process, the SSID to which the Rachio 3 was connected “bounced” several times as I executed the replacement and made additional config changes in the new AP afterwards. I expected I might have to reboot the R3, but it re-connected, all on its own, every time.

The only anomaly was, this morning, I found it associated with the WiFi AP out in the µBarn rather than the house AP. I bounced that AP and the R3 happily moved back to the house AP.

I just saw our Rachio 3 do the weirdest thing.

A final R3 WiFi connectivity test I’ve been meaning to do for a while was kick/ban the R3 on the Access Point to which it was connected and see if it would connect to the other AP. I wanted to see how it would handle seeing an SSID on a controller, but being refused connection. To see if it would try the other controller with the same SSID.

I did that, it connected to the other AP, and was reachable. So far, so good.

When I removed the R3’s MAC address from the AP upon which I’d kick/banned it, it re-connected to that AP right away–without having to be kicked off the other AP. That was kind of surprising, but ok.

What was weird was it stayed connected to the other AP at the same time!

And, yeah, it really was connected to them both at the same time, because the R3-specific SSID was passing traffic on both APs, simultaneously. The R3 was reachable, too. I force-quit and restarted the Rachio app on my phone and it connected to the controller.

I don’t have spanning tree enabled on any of our networking devices, but, I suspect that, if I did, that might have caused problems.

(Spanning tree is a Layer 2 protocol that improves network performance. Think of it as kind of an automatic L2 routing protocol. I leave it disabled because I found it can sometimes create problems when adding a new networking device.)