Gen 2 unable to connect to WiFi

I bought a gen 2 Rachio unit about 2 years ago and it was working smoothly until 2 weeks ago. During this time I had 2 new modems and 2 new network names and it worked perfectly every time I re-set the wifi. But unfortunately 2 weeks ago it went off-line and decided not be alive after more than 10 attempts to re-set. I removed the unit and brought it within 6 inches of the modem as well but the result was same. This was very frustrating and I created a support ticket but never got any support until now and it is more frustrating. I live in other side of the world Sydney, Australia and there is no local support either. Whenever I re-set it it goes back to the original offline position. i.e. keep on flashing of the 4th light. Can somebody please help me before I start regretting about my decision to buy a Rachio unit. Thanks, Mahesh

Has anything else changed with your network? Do you have the latest router firmware?

If you provide the code from this network scan I can have the engineering team review.


@Mahesh - can you describe the WiFi router equipment (make, model, separate bands, etc.)? Also what flavor of the Rachio app is being used to change/setup the WiFi - iOS or Android? (I’ve seen that iOS handles the networking better).

1 Like

It’s Sagemcom Wi-Fi router. It’s dual but we use only 2.4 GHz. Rachio worked without any problem for the last few months. No changes in network recently. Using IOS. Uses latest Rachio firmware -115

Make sure your router isn’t configured for wep encryption. Use wpa. Then make sure your router isn’t using a channel that isn’t approved for USA hardware. Some countries allow channels above 11 and hardware from the USA won’t connect to those likely.

This was working perfectly for the last 2 years until 2 weeks ago