Gen 2 - Schedule won't run

We’re starting our 5th summer with a Gen2 Rachio. Worked fine until this year. We can’t get any schedules to run.

I have looked at and checked everything I can on the link below and have confirmed nothing on there is causing the problem

Standby Mode is turned off.
Sensor terminals 1&2 have nothing connected and both are disabled
The Master Value wire is not connected and isn’t needed
We can manually run all of our schedules and it works fine.

The schedules are having these problems:

I sent Rachio Support an email on Sunday and haven’t gotten anything back. I sent them more details yesterday on everything I’ve tried and still nothing. Any other thoughts or help would be appreciated.

Are these all Flex schedules? The zone soil moistures could be high enough to not water (that doesn’t cause a “skip” event). Take a look at zone soil moisture chart and table to see if there’s any clues there,

These are Fixed Schedules. I needed something more consistent until I can validate that this is working like it should.

This still isn’t working for us. We’re manually starting the schedules every morning after we see that it didn’t start automatically. Hasn’t started on its own yet. I’m not sure that support knows what the issue is or how to help us. I’m waiting to hear if they can explain how we’re getting a “no skip” record and then nothing happens.

This is a long shot, but you could try deleting things and then redefining them. Occasionally (with pretty much any software program) there can be an unexpected hiccup — I would make sure I have all my settings written down (or screenshots). Then I would totally delete the schedules that are enabled and redefine them. Watch and see what happens. If that doesn’t fix things, then I would try redoing the zones.

@baersteven I had the engineering team review and the controller is thrashing pretty hard with reconnecting/disconnecting.

Can you create a test schedule that runs in a few minutes/hour from now and see if it runs? The controller could be running but not online? and reporting data.


We did that a few times when we were trying to figure out what was going on and they didn’t work. I created a test schedule to run at 7:30 tonight, a little over an hour from now. It shows that there is a next schedule, like it’s always done. I’ll check back after it was supposed to run.

I’m not sure why it would be disconnecting like that. We have a decent network at home and haven’t had problems with other devices. I’ll have to see if I can see anything on my end from my router.

It looks like you have setup a rain delay trigger from IFTTT? It has sent a rain delay command about 100 times over the last 3 days. Here is one example.

2020-05-09 05:59:01,149 [contextId=lyJ3qXehyF3] WARN {“body”:"{“triggerFields”:{“device_id”:“xxxxxx”,“event_type”:“RAIN_DELAY_ON”},“ifttt_source”:{“id”:“xxxxx”,“url”:“"},“user”:{“timezone”:“America/Denver”},“trigger_identity”:“xxxxx”}",“uri”:"/ifttt/v1/triggers/events",“t”:" 7357531c-d350-4f92-bc75-xxxxxx”}

I believe this is stopping your controller from running schedules.


That’s interesting. I was using ifttt to log details before a log was available in rachio. But I didn’t think it was still running. And it’s not setting a rain delay. It was supposed to be checking if it got turned on and logging it to a spreadsheet.

Based on their logs, I thought that meant it hasn’t run since 2017. I’ve disconnected ifttt so it won’t be calling into rachio. Maybe that was the issue.

Thank you for taking a look at this. It’s very much appreciated.

1 Like

OK great, let us know if that was the issue. The reconnects shouldn’t stop the controller from running, not ideal but it should run the schedules even with sporadic internet connectivity.

Looking further that might just be showing that the controller was put on rain delay. Ill have the engineering team do a bit more digging.


Ok, it doesn’t look to be IFTTT, Can you disconnect all the wires on the controller and create a test schedule and see if it runs? Seems like something is making the controller think it needs to bypass the scheduled schedules. Any rain sensors attached? If the controller doesn’t run after taking the wires off we can escalate to support and work on options there.


You want me to disconnect all the wires, liked to all the zones? I don’t have a rain sensor setup. Nothing is wired into this except the zones and it’s the same wiring I’ve had for the 4 years previous that had been working. I don’t want to pull it apart of that’s not what you meant. How do I know it’s working if I don’t have any of the zones attached?

If something is causing it to skip the schedule, do you know why we’re getting a log record saying that the schedule wasn’t skipped?

Sometimes bad solenoids can make the controller skip schedules by rebooting the firmware due to a current overload. One quick test to make sure its not a bad solenoid is to disconnect the wires (should only take a couple minutes). If after disconnecting the wires and testing if the schedules run or don’t, I will followup with our support team to get you straightened out.


We had a busy week, but we finally followed your suggestion. We removed all wires out of the device.
We setup a schedule to run an hour ago and there’s no record that the schedule ran. It shows up in the “Next Run” values. But when the time comes, it just disappears.

Screen shot of the next test schedule before it runs

At 10:30, it just disappeared with no record anywhere whether it tried to run.

I had the engineering team review and for some reason the controller is not persisting the calendar.

One more idea then will have to have the support team takeover. Can you try removing the controller from your account (controller settings) and then try a factory reset of the controller? You will lose zone pictures and setup but this might fix the state it seems to be in.

If not I understand, I don’t think the support team will be able to do much more than see if the controller is still under warranty.


We finally just decide to do a factory reset. Looks like it’s working now. It’s a pain to reset all the zones but I should have just done that a few weeks ago.

OK great, sorry you had to go through that, but glad you are back. Thanks again for your patience.


I am experiencing the exact same issue. Scheduled, then disappears. It appears the event is just lost from the schedule.

  • 5/22 no record
  • 5/24 skipped due to PLUS weather network
  • 5/26 no record

On both days it was scheduled to run the only record that exists is the history message, " was not skipped because the Plus weather…"

I will try a test schedule and if not running then a factory reset. I do have a rain sensor, but no skip is showing due to rain sensor. I will reply with my outcomes.

I picked up the device last week at Costco (5/19) , so if I need to return it I don’t think it will be a problem, unless they are out and can’t replace it.

Okay, seems to be up and running the schedule now. I went for the app reset first and worked.

Reset how to link - Option 1: Controller Settings within the Rachio app

1 Like