Gen 1 will not connect to WiFi Tp-Link AC2600 Archer A10

As the title suggests, after replacing my home router with a new TP-Link AC2600, my rachio gen 1 will not connect.

If it does, it will hold form 5min to 1hr or so, then drop.

Checking the logs on my router, I see it requesting an IP address, my router ack the request and sends an IP, but it continues to loop this process.

I’ve tried multiple different SSID’s, its on 2.4Ghz, its not mixed, my 5ghz is on a separate SSID.
I’m stuck. Using my phone as a hot spot, seems to work, so it looks like my gen 1 rachio doesn’t like my router for some reason?

I’ve contacted support a few times, usually get cut/paste responses (literally what happens), waiting to hear back from 2nd level tech, or their WiFi Experts. Hoping someone one here might be able to help.

I have combed the KB articles, nothing seems to apply to my situation. Any help would be appreciated.



*additional details that may be asked:

  • Rachio is 2.5’ away from the router
  • dozens of other devices connect to the wireless w/o issue, or drops (iphones, ipads, smart tv, smart switches, laptops, etc)
  • rebooted router many times, re-blinked the rachio countless times, on different SSID’s
  • have left the rachio unplugged for 24hrs (including the power brick)

This should be easy to troubleshoot.

There may be an IP address conflict. This could happen if the old and new routers have the same SSID and use the same LAN subnet, the old router gave out a long lease time, and you didn’t reboot all devices after installing the new router. You can test for this by temporarily powering off the Rachio and see whether the IP address it had been assigned responds to ping.

If that’s not it, let’s determine whether the trouble is with the access point part of the new router, or the routing part: Configure your old router with a different SSID and different LAN subnet from the new router. Connect the WAN port of the old router to a spare LAN port of the new router. Confirm that your phone can connect to the old router’s SSID and have internet access. Then configure the Rachio for the old router’s SSID and password. (This is double NAT but the Rachio should be able to tolerate that.) If this works, it’s the AP part of the new router that’s incompatible. If you don’t want to troubleshoot further and don’t mind the few watts that the old router draws, you can use it as a permanent workaround. Otherwise, please post all Wi-Fi settings in the new router (except passwords and anything else you feel is personal).

If the cascaded router test fails, I suspect some firewall setting in the new router. Temporarily set the minimum security level and report whether the Rachio can connect. If not, we can consider cascading the other way, using the new router as just a fast access point. Make/model of old router? Make/model of modem? Internet speeds up/down?

Thank you for the tips Stewart, unfortunately I’ve attempted most of these steps.

I’ve tried setting up a DHCP reservation, and not.
It’s been narrowed down to an issue with the router to the rachio, I can see the logs on the router:

Rachio sends a request for an IP
Router send an IP
Rachio sends a request for an IP
Router sends an IP

This loops 4-5 times then it fails and stops trying.

Very rarely I can get it to connect for 5min - 1hr, but it then drops and wont re-connect.

The old router is no longer available, however I am able to connect to a hotspot from my phone (tested for a few hours, it seems to hold), however its not a long term solution.

Its a new router, TP-Link AC2600 Archer A10
Full gig connection no issues with speed/latency

I’m stumped at the moment, all of my calls to rachio fall flat (no call backs from 2nd lvl techs)

@NewmanGT - just checking that the router and you are US based. There are additional WiFi channels available outside the US and I’ve seen posts where the router choose a non US band as it was the least congested and Rachio couldn’t access it. Doesn’t sound like that is the problem as there seems to be some communication - just checking.

Also, has the RouteThis app been run and the resulting code/key communicated to Rachio?

@DLane - thanks for the reply, I submitted a RouteThis via support ticket a couple times but it seems to have gone un-used or un-looked at.

I’m in an infinite loop of first level tech support who keep quoting the KB articles I’ve already tried. /rant

Sorry, just frustrated at this point.

I’m wondering if it needs a BTU adjustment, or channel it wants to connect on, I’m stumped as to why it keeps asking for an IP and not taking the one being handed out.

This should not be hard to fix, or at least to find out what’s wrong.

When the router repeatedly issues an IP, is it the same? If so, try running a continuous ping to the controller and report whether any replies come back.

In the router, if your 2.4 GHz network is set to N only, try B/G/N, or vice versa. You could also try B/G only for testing, but that’s a serious performance hit for other devices using the 2.4 GHz connection.)
Also, see whether turning off SPI Firewall helps.

If no luck, please report what resources you have that may be useful for troubleshooting. Do you have any Windows, Mac or Linux laptops with both Wi-Fi and Ethernet interfaces? Likewise for desktops, provided that they are (or can be) connected to the router via Ethernet. Any old routers or Wi-Fi extenders, even if B/G only? USB-to-Ethernet or USB-to-Wi-Fi dongles? Modem make/model? Internet speed?