Flex Daily doesn't work correctly

I have 10 zones and set to “end before sunrise”. The calendar makes no sense. Some days it set to run one or two zones at 4 pm when its 100 degrees. On other days it wants to run all zones for 14 hours when nothing was running in the days before. It looks like it is programmed to do this (sunrise - 14 hours) = 4 pm. When it should use the time to run the 2 zones (sunrise - 2 hours) = 4 am

I also tried changing “end before sunrise” to end by 6:30 am and did not fix the issue.

Also, there are like 30 other major bugs I have noticed using the app.

Isn’t Flex Daily the main feature of Rachio?? How do I get around this?

1 Like

Have you started looking at “more details” in the Moisture Levels for each of your zones? That should start answering some of your questions on what and why each zone is going to run.

Also, as another Rachio customer, I’d be curious as to what bugs you are noticing in the app. I am aware of a couple, but no where close to 30.

Unfortunately, Flex Daily will always start watering as if all zones were going to run. In your case, you have 14 zones with 14 hours of total watering time, so when you set end by sunset, it starts watering at sunset - 14 hours (which in your case is 4pm), even if only 1 zone is running.

This is not going to be fixed any time soon because according to Rachio, it will require a major overhaul of the code. And even if they did fix it, you might still end up with days where all zones need to water, and end up starting at 4pm anyway. I have suggested a different schedule where we could specify a start and end time, and Rachio would water the zones that require watering the most, and postpone the others to the next day.

In the meantime, there might be some other solutions to consider.

Change the schedule to start at a certain time instead of end at sunset. This gives you better control, and for the most part, not all zones will be running at once. And split the schedule to 2 schedules, odd and even days for example, so each schedule is 7 hours long. If you start watering at 1am, then worst case scenario, if all zones in that schedule are running, will be to finish by 8am.

Next look at how you can speed up watering. If you have enough water flow for 2 zones, maybe you can combine two zones (you can hook two solenoid to same zone in Rachio). So if you can find zones that share same characteristcs (slope, sun exposure), you can try this approach. Also, and probably the one that might require more effort, is to analyze the sprinkler heads you have to see if there are other options to increase precipitation rate.


Thanks, I split the schedule into two. Half the zones using odd days the other using even days. The even days run on odd days, so everything STILL runs on the same day lol… You can’t just make this stuff up +1 to bugs

Did you switch from End before * to Start at? You’ll need to start at after midnight so it works as you expect it.

Played around with it. With odd/even days it puts them all on the same day if I use “end before sunrise” for both. If I change one to say start at 5 am then it changes to odd and even days…

Made odd days all drip lines so it doesn’t matter as much if it ends at 10am. Don’t want to sprinklers watering while I am using the yard.

@ChrisWiles If you keep it start before sunrise, you’ll end up with surprises. I had this issue as well when I split my schedules to odd/even. It is better to use Start At schedule because the time will be deterministic. End at sunrise can cause issues if not now, maybe later when we get closer to summer solstice. I have mine scheduled to start at 1:30am. In my area, the wind is at its lowest during these early hours of the day. I am going through a replacement of sprinkler heads, and I am hoping I can double the rate, and then will be able to combine the schedule again. I still prefer to run a single schedule because right now the moisture level does not always reach Allowed Depletion before it waters, since Rachio will also tries to determine if the moisture level might reach Allowed Depletion before the next watering schedule (in two days), and water the zone prematurely.

@ moisture

Thanks. I got acceptable schedules working.

Schedule A: Sprinklers

  • Odd days
  • Flex Daily
  • End before sunrise

Schedule B: Drip lines

  • Even days
  • Flex Daily
  • Start at 4:30 AM

Not perfect but works ok

If you have drip lines, why not just start them after sprinklers. Drip lines are not affected by windy conditions or evaporation, so you can start them during the day. In my area, we have restrictions for sprinklers, but not drip lines. In this case, you can have two Flex Daily schedules, that can water any day, but one for sprinklers that waters at night, and one for drip lines that starts in the morning, e.g. 9am.


what @moisture said. If you have drip lines, it probably doesn’t matter if they run during the daytime. I have everything set as Flex Daily. My Lawn Flex schedule starts at 4:30am (I don’t use the end time, I figured out what start time I wanted based on the duration if everything ran, and I also let it finish up just a little after what is normally sunrise. I also don’t let it run on Thursday as that’s when my mowers are here). My Flower schedule (which is a spray and only runs for 9 minutes) runs at 8:00am. and can run every day. And then my drip zone schedule (which normally runs the longest and much more often) runs at 9:30am and can also run every day. This way I can use Flex Daily to it’s best advantage.

Wow, what a terrible UX decision. Selecting “end before x” actually means “start at time x” where the controller calculates time x in a mysterioius manner no consumer would expect.

People expect “end before x” to mean that the controller will calculate how long the night’s run will be and then start it at different times so it will end at the desired time.

I wondered why the “end before x” setting produced odd results. Now I know.

If I may make a suggestion… I had similar issues as you at first and then I figured a nice way around them…

Schedule 1: Grass
This covers all Spinklers for grass…
Flex daily (no water on Thursday’s since I mow my lawn on Thursdays )
End before sunrise

Schedule 2: Shrubs
This covers all drop lines
Flex daily start after sunset

This solves the issue of it starting while it’s sunny out. Never have any conflicts… and note I didn’t have to set odd or even days

Note shrubs is the second schedule on the list as well. So it will break up each zone if it needs to just to make sure it won’t interfere with the grass schedule.

One thing to know you can not have any two schedules end by sunrise. Same with start at sunset. Only one schedule for each of those.

By chance does the sprinklers you have set to water have enough zones and time total that they actually would start before midnight if it was to run all of them for their full length? That might be why you had the issue of watering on off and even days.

I am having the same problem described in this thread this year (did not have the issue last year, but I did recreate the schedule).

Given the length the defect has existed, from all appearances, it does not appear that Rachio has any intent of fixing this. Am I wrong?

Seems more like a choice than a defect in how they programmed it. Maybe after they get the HomeKit thing right they can start in on this…

1 Like