Fixed Schedule - Skip notifications coming at last minute


Recently dialed in my 6 zones, and created a twice a week watering schedule (M/F) to achieve 1" of water per week.

My last two scheduled runs (this past Friday, and early this morning) were skipped due to Saturation.
However, we have not had any rain since early last week.

I wasn’t worried about Friday’s skip, but I really would have liked it to water this morning.
I woke up to find a Saturation skip notification on my phone that I received at 3:48 am. The run was scheduled to start at 4:48 am.

2 questions:

  • Where does the controller get it’s ground saturation info from?
  • Why does the skip notification come so late (hour before scheduled run)?


For the saturation skip the system looks at last time the schedule watered and computes water balance based on duration and zone settings. After that event we use weather/zone settings to determine moisture level using crop evapotranspiration and observed precipitation until next watering, if moisture balance remains above zero, the saturation skip is triggered.

Schedules are checked at least 12 hours and 1 hour before the start time in order to catch latest weather changes.

After reviewing your schedule I did find a defect in our system related to re-validation between 12 and 1 hour check points. I will have a fix out today. Thanks for reporting this!

@OHWebs One more thing I’d like to add, with only watering on Monday and Friday (two days apart), you might see more climate skips than a schedule that is wider apart just due to the fact that if you water Friday and the system determines it can make it to next Friday it will skip Monday.


I’m assuming the only way this can be adjusted is through editing the zone settings? Or is it a pre-determined formula?

Thanks! Glad I could help…LOL:grin:
Does this mean that a notification/email should be sent at the 12 hour check point as well?

This makes sense. With my main goal of making sure that I get 1" of total water per week, then what would be the best way to accomplish this in the system?

Yes, zone settings can modify the moisture level produced by an irrigation event (precip rate, root zone depth etc). Crop coefficient affects how quickly zone loses moisture. The math is explained in a bit more detail in this thread if you are interested Irrigation + on field capacity chart not consistent with watering times.

You should only receive one skip notification, unless there is a change between the checks. If 12 hour check detected a skip you will receive a notification then, and if skip is still applicable at 1 hour check, then no notification will be sent as state hasn’t changed. In your case 12 hour check didn’t add a skip (correctly), 1 hour check added a skip (incorrectly - defect), hence the notification at 1 hour before as there was a state change.

If you added an extra day in between(?) or just turned off saturation skip would be closer to what you need.

I also recommend trying out a flex daily schedule on one or two of your zones. It will still water the duration you like but also track against true soil moisture levels and only water when it determines that amount is depleted.

Plus you get fun soil moisture graphs! :wink:


Thanks for the replies, Gents!

I’ll look it over and give it another go…

I do know, that when I played with creating my initial schedule that selecting Flex Daily set my watering times to close to 7 hours per run!
When I selected Flex Monthly it was a more realistic number of 5 hours per week based on 1" per week of water.

A post was split to a new topic: Flex daily recommended time watering too much