Double Notifications


#1

Is anyone else getting double ios notifications since the latest app release? I get 2 messages for everything now.


#2

Yes I get two as well.


#3

If you are receiving 2 notifications, try signing out and then back in to the app. We haven’t seen this behavior in our testing, but we are trying to track down why it might be happening for some people. When you sign out of the app it should try to “clean up” notifications tied to that device. We believe the issue may be because we have changed which “channels” we send push notifications over. If signing out and back in doesn’t clear things up, then the next step would be to try the notification reset process here: http://support.rachio.com/article/192-push-notifications-via-the-cloud. We understand that this process is a pain and apologize for the inconvenience. Please let us know if neither approach clears things up and we will continue to hunt down the root cause of this issue.


#4

this worked.


#5

Great! Thanks for letting us know.


#6

For what it is worth, my iPad has not received any notifications from ~8 days ago.


#7

I was seeing double notifications and signed out/in yesterday based on the advice above. This morning when my schedule started I started getting single notifications, and then I mysteriously started getting double notifications again. I can see it clearly in the notification center - “started xxx” / “completed xxx” / “started yyy” / “started yyy” / “completed yyy”. Note that only the “started yyy” is doubled and the corresponding “completed yyy” only came through once. Weird. It’s almost like it ties to send a notification, thinks it failed, and then retries.

The history in the app looks fine - no doubled entries.

Rob


#8

@rccoleman

Were you able to try the steps listed at the bottom of this article?

It only takes a few minutes and should get the app back to normal.

The issue is that when some apps were upgraded from 1.x to 2.x there might have been a residual notification channel listening to old events.

Hope this helps.

:cheers:


#9

Interesting - done. I’ll see how it goes in a few days.

For what it’s worth, it would be nice if the email field on the login screen used the “email keyboard”, rather than the normal one. It puts keys like “@” and “.” within easy reach.

Rob


#10

After following the instructions, I’m still getting double notifications. They’re often separated in time by several seconds. Anything else to try?


#11

I am going to disable the 1.x notification channel today. This should fix the issue. Will let you know when this has been promoted.


#12

Mine seems to be resolved just by signing out and then back in again. Hopefully it will remain solved.


#13

that fixed my phone, but i still do not get notificatoins on my ipad :frowning: