Connectivity issue for gen2


#1

Anyone have support ask you to put your gen 2 device as a DMZ on your network? Totally insecure and asking to get your entire network hacked. I’m getting the run around on why this thing won’t connect to the rachio servers when the wifi connects fine. Anyone else have this issue and what did you do to resolve it? My firewall settings on my fios router are sent to minimal (none) so I doubt it’s blocking anything. the logs don’t show any blocking.


#2

@wpcprez - I’m thinking Rachio support is just trying to determine the error domain, e.g. where the problem is and is not going to leave the Rachio device permanently in the DMZ.

Is your FIOS provided by Frontier or Verizon?

What make/model of WiFi router do you have?

Also, I think you also posted on the post that lists these ports but make sure they’re open:

Generation 2 53, 8883, 123
Firmware updates 80

Have you run the RouteThis app and sent the results to Rachio?


#3

fios was verizon and now frontier. Same router though it’s the newest AC1750 router they have. (Quantum Gateway).

Wifi router it’s connecting to is actually a linksys AC1900 (used in access point mode).

I saw that for ports 53,8883,123 but the posts said these were outgoing ports and not incoming ports. My fios router settings say minimum (no blocking for incoming or outgoing ports).

No they never asked me to use routethis app. No idea what it is. An android app? PC app?


#4

@ wpcprez - For RouteThis see -> https://support.rachio.com/hc/en-us/articles/115010540888-Is-my-WiFi-Network-Compatible-

So the Linksys AC1900 I believe is a dual band router, are the SSID’s different for the 2.4 GHz and 5.0 GHz networks?


#5

yes they are different and I have the device connecting to the 2.4 which it does fine. Even tried to connect to a different AP and still have the same issue. Will try routethis when I get home tonight after work. Thanks


#6

@wpcprez - I might try starting a packet capture on the Linksys and then restart the Rachio device to see what is going on. Wireshark, or something similar, will be needed to look at the PCAP file created by the packet capture. That is me, not sure if this is above and beyond for you.


#7

no prob but not sure if the linksys can redirect all to a port for packet capture since it’s just a dumb AP. their frontend removes a lot of functionality when you set it to AP mode. But even with that, if I have to spend a lot of time troubleshooting something that should just work I will likely just return this and go with a different unit. We’ll see, I’ll check the traceroute app and see what it says.


#8

@wpcprez - understood on all counts. For what it’s worth, my install went seamlessly. I might also suggest scheduling a live call with one of Rachio’s networking support folks. From what I’ve seen they typically get the issue figured out.

Also, to be clear is light two solid and light three flashing? If not, which light is flashing?


#9

So from the beginning…

1 one light solid 1 fladhing
2 run app, it finds device. Select device and pick WiFi network and serial #
3 second light goes solid and third light flashes
4 eventually the app gives up and says to try again or reset device.

Tried WiFi reset and full factory reset and neither got any further. Also tried to join a guest Network and a different AP that was 2.4 as well but didn’t work.

I usually don’t get home in time to call them but I’ll try on the weekend if I can’t get it to work .

Thanks for your help

Update… So I have a working solution. Don’t use the Android app. My brother in law set it up with same router setup and his setup fine. The only difference is he has apple and I have Android. Used my daughter’s iPod touch and the setup went perfect in one setup and now I can manage it on both devices.

Sorry but that is pretty sad that using an iPod touch is the solution and rachio can’t get a flagship phone like the Samsung Galaxy S7 on the latest Android working properly.


#10

@wpcprez - thanks for letting the community know how the problem was solved.

I’ll forward this to contacts at Rachio to make sure they see it.


#11

@DLane Thanks for help troubleshooting.

@wpcprez Thanks for the update. We do appreciate letting us know when certain phone configurations have issues. I’ll have our team do some testing with this specific setup.

Thanks again, and please let us know if you have any other issues or questions!

:cheers:


#12

So I’ve joined the “beta” program for the new v3 app. Which worked fine since everything was already setup. But I’ve recently reset my wifi password so I did the network reset to join the new network. And guess what? The new app has the same issue the old app had and cannot configure the device correctly. So then I tried my last workaround and can’t login the v2 app on the apple. I assume this is because I’m in the beta program for v3. This is all assumption because I cannot reset my password or login via the web because the return back from a chrome debug console says “user on v3 app and needs to use v3 app”.

So the question is, android configuration of wifi still doesn’t work and im on the v3 beta. What do I do now? How do I get off the beta program or some how get the v3 app for my daughters ipod touch? When will the app be fixed to work properly on a Samsung Galaxy phone? Previous was an S7 and now an S8 Plus and I have the same configuration issues with the app I had a year ago. I’m surprised nobody else has had the same issue and could not configure the device.


#13

@wpcprez - use the Contact Us under the Help Center in the app to send a ticket to Rachio with the above information.


#14

I emailed beta@rachio.com but was hoping someone here might have a solution


#15

Can you elaborate on this? I can have our Android team review and get a fix for this if we can determine what the issue is.

Thanks!

:cheers:


#16

Good to hear that a V3 Beta program is alive and well. Today’s first time in quite some time I’ve seen a posting that confirms it still exists. Someone really is going to win the contest.

I have a Samsung Galaxy S7, along with (formerly) Verizon (now Frontier) FIOS fiber optic service - all worked fine when using the Verizon supplied combo modem/router/switch/AP. Didn’t have to pay attention to 2.4 versus 5.0 Ghz stuff. No messing around with opening ports.

Last year I turned off my AP integrated into the Verizon supplied unit, and replaced the AP functionality with a Ubiquiti UniFi AP-AC-Lite standalone AP. Again, all worked fine, including not having to pay attention to 2.4 versus 5.0 GHz stuff, or needing to mess around with opening ports.

Best regards,

Bill


#17

Hello,
I am on frontier fios now and I’ve tried the stock verizon/frontier routers and ASUS routers and I don’t think this has anything to do with the routers or internet service. Back when I first purchased this unit which you can see from my first post here I had the exact same issue. When trying to setup from a Samsung Galaxy S7. But since them I’ve also upgraded to a Galaxy S8 Plus and the same issue.

You basically reset the wifi, go into the app and tell it that it’s getting a new wifi but it always just hangs there saying the rachio is connecting to the wifi. But when done from an apple device it worked in 1 try. The main issue right now is now that I’m on the v3 beta I don’t have access to a v3 beta apple app so I can’t fix my own issue.

The only reason I assume this is I can’t even login the website https://app.rach.io/. It just says “No user found with that username/password combination”. But if you do a debug and look at the json response from the login the raw response to the web browser says

{loggedIn: false, message: “Person migrated to v3.0 software, please get new Rachio app.”}
loggedIn
:
false
message
:
“Person migrated to v3.0 software, please get new Rachio app.”

fyi - ticket i have open is 226481


#18

ok so a really strange thing happened. I came home from work yesterday and now my rachio app says my unit is online with the new wifi network/password. But I wasn’t even home to try anything. Could my issue have been server side and the person handling my ticket fixed something? No idea… but it is working now and I’m afraid to try to “reset” the wifi to see if I can replicate the issue.