Can't set start at a specific time

Hello, It is time to change my watering clock. I tried this morning and even though I can get to the screen, upon setting the new time nothing gets updated or sent to my controller. All other setting changes are working OK. I have a Rachio 3 using iOS 14.1 .


Even when you do it from ? Even when you tried from another device such as your desktop or laptop computer?

From , select the schedule, click Times, click Start at specific time, click start hour, click start minute, click OK, click Done. You should see an Updating Schedule mesaage.

Using the cloud app works ok. The problem is with the phone App. It has to do then with the latest apple iOS 14.0.1. Please fix the phone app. The beauty of Rachio is that it exist on your phone.



Hey Eric,

I’m running this on iOS 14.0.1 with the latest version in the App Store. Here’s a recording of what I see when changing a schedule’s start time. In this case, changing from “Start after Sunset” to running at 6pm.

What’s happening for you when you try this?

Or is the issue you’re seeing something different?

My problem seems to be only whe using start at a specific time. I get the rolling numbers to set the clock and the AM and PM, but upon clicking DONE, it does show the UPDATING screen. The window closes and turns gray. If I tap it again then I am back to square one.

Thanks for the info.

I’m wondering now if it’s a miscalculation with the keyboard maybe.

When you’re changing the time, are you using the keyboard, or does the keyboard appear while changing the time? Or are you scrolling the time into position?

Also, if you don’t mind sharing, what device are you using? That may help me debug it

This is the screen that comes up. No keyboard appears. By device, do you mean Rachio 3??


I was thinking phone device, maybe there was a layout issue with one phone model, but looks like we have the same or at least similar phone. So I don’t think that’s the issue.

When you tap done from that screen, it shows “updating…” then just goes into a gray screen? Do you see anything else when it’s that gray screen or is it just gray and nothing else is there?

Could you also let me know what app version you’re on? You can see that on the more tab -> account and it’ll be at the bottom of the screen.


Sure he is the pic. Also the firmware is: iro3-firmware-hk-5-632

Sorry I have an iPhone XS Max running iOS 14.0.1

Once I set the time and click UPDATE it does not flash/show updating. The screen just turns dark gray.


Same problem here. iPhone 12, trying to setup a simple 3rd schedule where I can have the 2 front lawn sprinklers go on for 1 minute each at 1:00 am. I go to e yet the time and it grays out like op and defaults to before sunrise

Just got my unit and installed the app and found this problem in iOS.

When I select a start time e.g. 2:00am it goes back to 7:00am.

I wondered if it defaulted to 7am at the earliest since the field was “start after” (which is odd because it goes into the field labeled “start at”) and tried to enter 6:00am… the result was 11:50am.

I logged into the web portal and was able to easily* set the start time to 2:00am

How is this still a bug after 2 years?

*the control for selecting time on the web was really awkward. Drag an hour hand around an analog clock for hour and then another hand for minute. Just give me a selector for hours and minutes please.