Can’t get my Rachio to connect to HomeKit

After overcoming the hurdle of getting my Rachio on my Wi-Fi network (see my other post), I tried to connect it up with my Home (HomeKit) app. Here is what I encountered:

I went into the Home app and tapped the plus sign in the upper right and selected “Add Accessory.”

On the screen above I tapped on “I Don’t Have a Code or Cannot Scan.” This brought up a screen that showed the Rachio as a HomeKit bridge. I tapped on that.

I then entered the Rachio’s HomeKit Setup Code from inside of the Rachio iPhone app:

After that, I saw this for a little while:

However, it ended up with “Unable to Add Accessory:”

I checked that the Rachio was still connected, and it was:

And I checked the firmware version, which is the latest (iro3-firmware-hk-5-632):

I’d be grateful for any ideas on how to fix this.

Oh, looking at other posts this seems to be relevant: my Wi-Fi network is a 4-node Linksys Velop mesh network.

There’s a very large thread over here. The TL;DR is it’s a known issue that isn’t fixed yet.

1 Like

I shut down all but the master nodes of my Velop system. My Rachio is close to that one. I had to power-cycle it once to bring the Rachio bridge back in the Home app, but the Home app could still not add it as an accessory.

Basically HomeKit is broken with the Rachio and after two years of saying they will fix it, its still is broken.

False advertising saying it works with HomeKit.

I have to constantly re-add it back into HomeKit. Sometimes this is quick and easy and other times it is a nightmare to add back in.

Personally I think Rachio should buy back all their controllers as clearly it doesn’t work much of the time.

I am not willing to go that far. However, I would appreciate an ongoing show of commitment to fixing this problem. I have no idea, how difficult this is, really. Regardless, I am open to helping in any way I can. Right now I have another two or three weeks, before my irrigation system gets turned back on and I will proceed to replace my Rain Bird unit with the Rachio 3. In other words, I can do so without harming anything, as my unit is just sitting on my desk, all lit up blue.

Fixing the issue has been a massive project for them that they have been working on for months because it’s required them to spend a lot of money and have part of their system rebuilt from the ground up. It will get fixed, they post excellent updates every so often in that other thread. But I’m guessing it will still be a few months before the fix is rolled out to everyone’s controllers. They will have beta software to test the fix first, and following the other thread will keep you update on that.

I am a software architect at a company the builds devices that are homekit certified. ( and have done similar at a previous company ). I could’ve re-written a homekit stack from scratch in the time it’s taken them to STILL not have a working system. There is absolutely no excuse for not having this fixed, unless the company they outsourced this part of their product to is completely incompetent. Or they went with extremely cheap hardware that isn’t worth the sand that the silicon was made from. In either case, within the first year, any sensible company would have brought in a better team and/or replaced the broken software/hardware with something certified to work, even if it was more expensive. There is no excuse nor is there any reason this should still be this broken.

2 Likes

I am suspicious of the hardware. Why can’t they get it sorted? I’m surprised apple hasn’t caught wind of this :flushed:

Apple doesn’t police Homekit devices after they’re certified.
They were able to get it to work well enough during certification/testing so at least the SW/HW combo worked then. I suspect an update or slight change in HW…

It’s been two years now. I think they don’t know how to fix it or it is unfixable. They bricked the controllers of the beta tested and had to replace them. I find it odd that they aren’t first testing on their own controllers for testing first.

Yeah, really no excuse. For example If they went to an Espressif chip, the SDK has a homekit stack that works pretty well. And they are cheap. So no idea WTH it’s taking this long.

I purposefully bought a Rachio 3 ( and sold my previous Rachio 1) because of the homekit support.

So far, I’ve not been able to keep it paired more than 2 a few hrs or so.

@Ebaugh Earl, can you consult with Rachio (for a fee, of course) and get us rock solid HomeKit support?

I’m with @Ebaugh on this. I’m in a similar situation as he is, enjoying a so-far three-decade-long career as a software developer of many apps that run on many platforms. A handful of the apps I’ve worked on integrate with Homekit. It is not “rocket science,” as they say, to get HomeKit integration to work. Like anything, it requires attention to detail, best practices, reliance on or in consultation with experienced professionals, and good testing. Any number of reasons could have (but shouldn’t have) caused these problems. The fact that we are about two years out with no rock-solid solution in the hands of every customer including those who will, for the first time, receive a Rachio controller shipped from the distributor tomorrow or afterwards speaks of ongoing, questionable software, hardware (or both) engineering practices. What’s worse is that Rachio has made promises made but not kept them, then made more promises made and not kept those. The latest round of promises for Homekit integration were Fall 2020, then Winter 2020, then Spring 2021. Here we are. From what I can tell – and it’s hard to know because Rachio’s engineering team lead refuses to live by any hard dates (or so it seems) no matter how far in the future they are – we are still not very close. Or at least Rachio’s engineering team lead is no longer offering hard dates in these forums. My guess, and that’s all it is, is that we’re unlikely to see a general release of the software that supports Homekit until the summer. That’s only ten weeks away, which is about the minimum length of time a beta of this sort should run, in my opinion; however, I’ve yet to hear about any beta software being released to those who have signed up to be a beta tester. So maybe a general release will get pushed to mid-summer.

2 Likes

I’m not necessary to solve this problem. (and I already have a full time job :slight_smile: )

There are plenty of companies that can do this and plenty of good engineers who can as well. I suspect they’ve gone with “cheap” over “good”…

Not sure if anyone else finds this helpful, but in the interim, while we wait for Rachio to resolve the problem officially, there is a perfectly functional plugin for HomeBridge.io that works reliably. I had already set up a HomeBridge server to overcome insufficient official HomeBridge connections from LG & Chamberlain. 30 seconds to install plugin and grab my API key and HomeKit works again for the first time in months.

1 Like

I am new to Rachio and am running into the same issue that is listed in this thread. Unable to connect my Rachio 3 to HomeKit. Looking for suggestions.

Everyone in this thread is waiting for the company to release a firmware update that will fix the issue you are having.

1 Like

My Rachio has the IP address 192.168.4.8 on my LAN. Using the Discovery utility that browses the network for advertised Bonjour services, that IP address does not occur anywhere in what it finds. Why is the Rachio not even trying to advertise anything?

I was able to add my Rachio 3 to HomeKit for the first time today. The key was to turn off the Avahi daemon running on my pfSense box.

Yep. Except the chances of it staying connected are nill to none. Hey Dominik, if you ever have a few days on nothing going on, check out the long thread that you were copied on.