Calibration process freezes upon completion

Received a “Low-Flow Detected” warning yesterday in one of my drip lines so decided to recalibrate my WFM. Ref. two screenshots below. The first shows the calibration status with 3-4 seconds remaining. At this point, neither “Use Current Value” nor “Cancel” are even active (i.e. I tap them and nothing happens). When calibration finishes (4 seconds later), what you see in the second screenshot appears … and the app freezes, except the water animation. It doesn’t automatically advance to the next screen to lock in the flow rate, as it always has in the past, nor is “Cancel” active. Instead, I must close/dismiss the app entirely. Any ideas? All 9 of my zones calibrated just fine a couple months ago.

I have the same issue, wanted to know how you fixed it or if there is a bug in the app that needs to be fixed?

Thanks for the reply. Good to know I wasn’t imagining things. I’ll try calibrating a zone or two later today and post the results here.

@jamestford @laura.bauman @franz Seems like something has changed within the app that has broken the calibration process. Just calibrated the same drip zone (backyard drip) as in OP and as you can see in screenshot #1, with 15 seconds to go the calibration process looks great. 15 seconds later, upon calibration completion, it just freezes (stalls) except for the blue water animation. Cancel isn’t even active and I must close/dismiss the app. So, definitely still happening. Currently running version 4.1.10 of the iPadOS app. Calibration of all 9 of my zones worked fine on May 1st. I’m not sure what 4.1.x version of the app I had installed then, either 4.1.3 or 4.1.4 I would guess.

1 Like

Same issue here as well. Just installed today-everything else is good. Freezing occurring on both my iPhone 8S and iPad Pro.

Hey guys, we’ve got this fixed in an update scheduled to come out Monday.

Basically, something gets cleared from memory while the calibration is happening and that prevents additional zones from calibrating.

We’re waiting on Apple to approve a beta release of the app that should come out before Monday and I can post that link here when available. That way you can calibrate as normal this weekend (given it gets through the review by then).

If you need a potential work around before the next release is available. You can try calibrating one zone at a time view the zones tab and clicking into edit each zone -> flow settings. The calibration should still be reported to the server and saved even though the app may not display the updated value. If you still cannot close out of that screen to continue with the next zone, you can force close the app and relaunch and continue with the next zone.


Nice work tracking this down! Will test the updated app when it appears in the App Store. :+1:

Thank you for the quick response-will be looking for the update!

1 Like

Thanks guys! Wanted to give an update that Apple approved the beta app that can be downloaded and used before the full app store release we have planned for Monday.

If you don’t want to wait until Monday to get the update from the app store like normal you can follow this link to install the beta:

The beta process has you download Apple’s TestFlight app that acts as a pre-release type of store. You can then download apps that you have beta access to from there and it installs over your existing app. The beta generally only stays active until the app store version is available for everyone. At that time the beta will expire and the when you try launching the beta app it’ll ask you to update or re-download the app from the app store.

1 Like

Calibration in the updated i(Pad)OS app v. 4.1.11 works great. Thanks @zachio for the quick response. :+1:

1 Like