Android app can't update zone settings


#1

Mostly I use Android for my mobile devices. Fortunately my wife has an iPad mini for running a specific knitting program. We had to use that device to blink up the Iro.

I can start and stop zones from the Android app on my phone, but it fails if I try to update something in the zone configuration such as the watering area.When I click “save” it goes into a “Please wait” state and does not come out of it. Finally Android will tell me that the app has stopped responding and allow me to close it.

Making these changes works just fine from the iPad.


#2

Hi again, @sbillard, thanks for reporting this. We haven’t heard of any issues from any of our other Android users. :confused:

Have you attempted to log out of the app, close it and restart it yet? Assuming you have and the issue continues, please email our support team [support@rachio.com] and we’ll do some further troubleshooting with you.

Best, Emil


#3

Was able to reproduce, will let you know when we have a fix. Thank you for providing this information!

:beers:


#4

@sbillard This fix has been submitted to the Google Play Store. Will be available in a few hours.

Version name 1.9.2–72

:beers:


#5

I confirm that the fix works. Thanks.


#6

Fantastic, thanks for your patience and reporting this defect.

Odd it only affected certain phones, but Android is a different OS to tame :wink:

:beers:


#7

Hi I just purchased your controller and it’s awesome. However I ran into this issue as well. The app version I downloaded for Android matches the version you mention here but although I was initially able to set up my zones and watering times something happened and now I get the same issue as described in this post. I can use the app to start and stop zones and schedules but I can no longer edit the individual watering times. It seemed to occur when I added a disabled watering schedule that I planned to enable later this month when watering restrictions are in effect. I tried to delete it in the app to resolve the issue but it won’t disappear from the list. Its the same on both my phone (HTC one m8) and my tablet (nexus 10).

If it helps I have 8 watering times set up with 7 enabled (growing some new grass so watering is frequent). The problem seems to have occurred after I added the 8th watering time and disabled it.

If you need more information please let me know. Thank you.


#8

@olorin1984 Thanks for reaching out to us.

Can you tell me the version # of the Android app you are using?

Tap the left slider menu and the version # will be on the bottom.

Thanks!

:beers:


#9

It is 1.9.2-72


#10

@olorin1984 Thanks, was able to replicate. Having our Android developer review and we should have a fix out soon. So strange that Android has been rock solid for months and now we see these random issues. Huge amounts of new users which is shaking out these edge cases.

Thanks for your patience and we’ll get this fixed today.

:beers:


#11

@olorin1984 Ok fixed and published to the Google Play store.

Look for 1.9.3-73 in the next few hours.

Thanks for your patience, and please let us know if you have any issues or feedback.

:beers:


#12

Thanks for the quick response! The fix worked for me. All is well. Have a nice weekend.


#13

Apparently the problem has returned. I have a galaxy s5 and galaxy tab. Neither can add a water schedule. It just stays on please wait after clicking add My phone is on lollipop 5.0 and the tab is on 4.4.4. Both are using iro version 1.9.3-74 ’


#14

@raptor1418 Can you please email support@rachio.com ? They will be able to diagnose and try to reproduce the issue by working with the development team.

Thanks!

:beers: